Partilhar via


O erro 80040203 de código de erro (Argumento Inválido) ocorre quando você tenta importar uma solução para a Microsoft Dynamics 365

Este artigo fornece uma solução para um erro que ocorre quando você tenta importar uma solução para a Microsoft Dynamics 365.

Aplica-se a: Microsoft Dynamics 365 Customer Engagement Online
Número de KB original: 4514229

Sintomas

Ao tentar importar uma solução no Dynamics 365, você recebe a seguinte mensagem de erro:

"Falha na importação da solução: <o nome> da solução falhou.
Código de erro 80040203".

Observação

Este código de erro está documentado em códigos de erro do serviço Web com as seguintes informações:

Nome: InvalidArgument
Hex: 80040203
Número: -2147220989
Argumento inválido.

Motivo

Esse erro pode ser causado por vários motivos. Se a caixa de diálogo de erro fizer referência ao seguinte tipo de objeto, examine o restante deste artigo para obter uma solução em potencial:

Tipo: Relação
Nome: bpf_<entity>_<publisher>_<BPF Name>

Baixe o Arquivo de Log que, quando aberto para a página Componentes, mostrará:

ItemType: Relação de entidade
Nome: bpf_<entity>_<publisher>_<BPF Name>
ErrorCode: 0x80040203
ErrorText: Nome de exibição de atributo para id: <GUID>, objectcolumn: DisplayName e labelTypeCode: Atributo não especificado

O Nome da Relação de Entidade será a concatenação de uma Entidade e um BPF (Fluxo de Processo empresarial). A Entidade foi removida anteriormente de um estágio BPF e substituída por uma entidade diferente e, em seguida, o BPF foi atualizado enquanto ainda estava ativado. A entidade foi removida do BPF, mas a relação ainda existe no esquema. Portanto, ela é exportada com a solução da origem. Essa relação está fazendo com que o erro seja exibido.

Resolução

A Microsoft está ciente desse problema e está trabalhando em uma alteração para remover essa relação após uma exclusão e, em seguida, atualizar.

Existem duas soluções alternativas para esse problema:

Opção 1 – Atualizar arquivo de solução

Se você precisar importar a solução e não conseguir recriar o pacote de solução, remova a relação da solução.

  1. Descompacte a solução.

  2. Edite o customization.xml.

  3. Pesquise a relação mencionada no erro: bpf_<entity>_<publisher>_<BPF Name>

  4. Exclua todos os XML para a EntityRelationship:

    <EntityRelationship Name="bpf_<entity>_<publisher>_<BPF Name>">
    ...
    </EntityRelationship>
    
  5. Salve o arquivo.

  6. Feche o diretório inteiro.

  7. Importe a solução novamente.

Opção 2 – Remover a relação da origem e recriar sua solução

É uma resolução de longo prazo e corrigirá o problema para a próxima exportação da solução.

  1. Abra a organização de origem.

  2. Selecione Configurações / Personalizações / Personalizar o Sistema

  3. Selecione a Entidade na relação:

    bpf_<entity>_<publisher>_<BPF Name>
    
  4. Expanda relações 1:N.

  5. Localize a relação:

    bpf_<entity>_<publisher>_<BPF Name>
    
  6. Selecione e exclua a relação.

  7. Publicar Todas as Personalizações.

  8. Exporte a solução e importe-a para o destino.