Problema explícito do SPN no local incorrido no SQL Server
Este artigo ajuda-o a resolver um problema de autenticação consistente do SQL Server que afeta o Nome do Principal do Serviço (SPN) incorrido no local incorrido.
Sintomas
Se o SPN que especificar na cadeia de ligação existir numa conta de serviço que não é utilizada pelo Microsoft SQL Server, receberá uma mensagem de erro de contexto da Interface do Fornecedor de Suporte de Segurança (SSPI).
Se o SPN não estiver registado corretamente, poderá receber a seguinte mensagem de erro:
O nome principal do destino está incorreto. Não é possível gerar contexto SSPI.
Se tentar criar um SPN que já existe, receberá a seguinte mensagem de erro:
SPN duplicado encontrado, a abortar operação!
Motivo
Os SPNs explícitos no local incorrido podem causar problemas na autenticação Kerberos e impedir que os clientes se liguem ao serviço.
Solução
Se estiver a ter SPNs explícitos no local incorrido, poderá ter de criar ou recriar o SPN para o serviço. Para criar ou recriar o SPN com o SETSPN
comando , siga estes passos:
- Execute o
SETSPN -L domain\svcacct
comando para listar SPNs na conta de serviço do SQL Server. - Execute o
SETSPN -Q spnName
comando para saber em que conta de serviço o SPN está registado. - Execute o
SETSPN -D
comando para remover o SPN do serviço. - Execute o
SETSPN -A
comando para adicionar o SPN ao serviço. - Mova o SPN com
SETSPN -D
ou selecione um SPN que já exista na conta correta.
Mais informações
Comentários
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