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Erros de conexão intermitente ocorrem ao adicionar um nó ao ambiente Always On no SQL Server

Você experimenta erros de conexão intermitente ao adicionar um novo nó ao ambiente Always On existente.

Sintomas

Quando você tenta se conectar a um servidor que está executando o Microsoft SQL Server, a seguinte mensagem de erro aparece intermitentemente:

A conexão foi estabelecida com êxito com o servidor, mas ocorreu um erro durante o processo de logon. (provedor: Provedor SSL, erro: 0 – Uma conexão existente foi fechada à força pelo host remoto.)

Motivo

Esse erro poderá ocorrer se houver uma incompatibilidade nos protocolos de segurança entre o banco de dados e os servidores de aplicativo.

Resolução

Para corrigir esse erro, resolve a incompatibilidade entre os protocolos de segurança. O Node1 criptografa informações usando o AES128/256. O Node2 criptografa informações usando o RC4. Para solucionar esse erro, siga estas etapas:

  1. Baixe o IIS Crypto.

  2. Instale a versão gui da ferramenta IIS Crypto no servidor.

  3. Configurar o Cipher Suites.

  4. Abra a ferramenta IIS Crypto no servidor.

  5. Na interface do IIS Crypto, selecione Cipher Suites no painel esquerdo.

  6. Na lista, desmarque todas as caixas de seleção para as cifras que começam com "TLS_DHE*".

    Observação

    A lista pode não estar em nenhuma ordem específica.

  7. Depois de limpar as seleções de criptografia relevantes, selecione Aplicar para salvar as alterações.

    Captura de tela que mostra a limpeza de todas as cifras que não são necessárias.

  8. Reiniciar o servidor.

    Depois que as alterações forem aplicadas, reinicie o servidor para garantir que a nova configuração do pacote de cifras entre em vigor.

Observação

Esse processo de solução de problemas força o cliente a se comunicar usando um pacote de cifras diferente que tenha uma implementação de segurança aprimorada.

Certifique-se sempre de ter os backups apropriados disponíveis. Além disso, considere testar quaisquer alterações em um ambiente controlado, encenado ou de teste antes de aplicá-las aos computadores de produção. Se o problema persistir ou se você tiver outras preocupações, entre em contato com sua equipe de rede.

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