Ошибка "Файл уже существует" при настройке Microsoft Dynamics CRM для Microsoft Office Outlook

В этой статье описывается решение ошибки, возникающей при настройке Microsoft Dynamics CRM для Microsoft Office Outlook.

Область применения: Microsoft Dynamics CRM Online, Microsoft Dynamics CRM 2016, Microsoft Dynamics CRM 2015, Microsoft Dynamics CRM 2013, Microsoft CRM клиент для Microsoft Office Outlook
Исходный номер базы знаний: 3183053

Симптомы

При попытке настроить Microsoft Dynamics CRM для Microsoft Office Outlook появляется следующее сообщение об ошибке:

"Существует проблема при обмене данными с сервером Microsoft Dynamics CRM. Сервер может быть недоступен. Повторите попытку позже. Если проблема не исчезнет, обратитесь к системному администратору.

Файл уже существует. Попробуйте использовать другое имя базы данных. [ Имя файла = C:\Users\<USER>\AppData\Local\Microsoft\MSCRM\Client\MetadataCache-5243bc89-09f7-4d12-b578-8efd890f5d7c.sdf ]..."

Причина

Эта ошибка может возникнуть, если файл базы данных из предыдущей конфигурации уже существует для экземпляра CRM.

Разрешение

Вариант 1 (CRM Online)

  1. Если вы используете CRM Online, вы можете запустить помощник по служба поддержки Майкрософт и восстановлению, чтобы устранить эту проблему.
  2. Выберите параметр Dynamics CRM Online, а затем выберите У меня возникли проблемы с установкой, подключением или включением CRM для Outlook (клиент Outlook).
  3. Продолжайте работу с мастером. Должно появиться действие Удалить файлы кэша, используемые CRM для Outlook, и будет удален существующий файл, на который ссылается ошибка.
  4. Снова запустите мастер настройки Microsoft Dynamics CRM.

Вариант 2 (вручную)

Если вы не используете CRM Online или предпочитаете устранить проблему вручную, выполните следующие действия.

  1. Закройте Outlook.

  2. Откройте windows Обозреватель и перейдите по адресу <install directory>:\Users\<Your User>\AppData\Local\Microsoft\MSCRM\Client.

    Пример: C:\Users\<username>\AppData\Local\Microsoft\MSCRM\Client

    Примечание.

    Папка AppData по умолчанию скрыта. Вы можете изменить параметры Представления, чтобы отобразить скрытые элементы, или скопировать и вставить следующий путь в папку:
    %localappdata%\Microsoft\MSCRM\Client

  3. Удалите файл, указанный в сведениях об ошибке.

  4. Снова запустите мастер настройки Microsoft Dynamics CRM.