При настройке файла уже существует ошибка Microsoft Dynamics CRM для Microsoft Office Outlook
Эта статья содержит решение ошибки, возникающее при настройке Microsoft Dynamics CRM для Microsoft Office Outlook.
Применимо к: Microsoft Dynamics CRM Online, Microsoft Dynamics CRM 2016, Microsoft Dynamics CRM 2015, Microsoft Dynamics CRM 2013, Microsoft CRM клиента для Microsoft Office Outlook
Исходный номер базы знаний: 3183053
Симптомы
При попытке настроить Microsoft Dynamics CRM для Microsoft Office Outlook возникает следующее сообщение об ошибке:
"Возникла проблема с взаимодействием с Microsoft Dynamics CRM сервером. Сервер может быть недоступен. Повторите попытку позже. Если проблема не исчезнет, обратитесь к системному администратору.
Файл уже существует. Попробуйте использовать другое имя базы данных. [ Имя файла = C:\Users\< USER>\AppData\Local\Microsoft\MSCRM\Client\MetadataCache-5243bc89-09f7-4d12-b578-8efd890f5d7c.sdf ]..."
Причина
Эта ошибка может возникнуть, если файл базы данных из предыдущей конфигурации уже существует для экземпляра CRM.
Решение
Вариант 1 (CRM Online)
- Если вы используете CRM Online, можно запустить служба поддержки Майкрософт и помощник по восстановлению, который может устранить эту проблему.
- Выберите параметр Dynamics CRM Online, а затем у меня возникли проблемы при установке, подключении или включении CRM для Outlook (клиент Outlook).
- Продолжите работу с мастером. Должно появиться действие "Удалить файлы кэша", используемого CRM для Outlook, и будет удален существующий файл, на который ссылаются в ошибке.
- Снова запустите Microsoft Dynamics CRM конфигурации.
Вариант 2 (вручную)
Если вы не используете CRM Online или предпочитаете устранить проблему вручную, выполните следующие действия.
Закройте Outlook.
Откройте проводник Windows и перейдите к
<install directory>:\Users\<Your User>\AppData\Local\Microsoft\MSCRM\Client
.Пример:
C:\Users\<username>\AppData\Local\Microsoft\MSCRM\Client
Примечание.
Папка AppData по умолчанию скрыта. Вы можете изменить параметры представления, чтобы отобразить скрытые элементы, или скопировать и вставить следующий путь в путь к папке:
%localappdata%\Microsoft\MSCRM\Client
Удалите файл, указанный в сведениях об ошибке.
Снова запустите Microsoft Dynamics CRM конфигурации.