Примечание.
Для доступа к этой странице требуется авторизация. Вы можете попробовать войти или изменить каталоги.
Для доступа к этой странице требуется авторизация. Вы можете попробовать изменить каталоги.
Важно
Эта функция находится в режиме публичной предварительной версии.
Драйвер Databricks Driver for SQLTools позволяет использовать расширение SQLTools для Visual Studio Code для просмотра объектов SQL и выполнения SQL-запросов в удаленных рабочих областях Azure Databricks.
Requirements
Прежде чем использовать драйвер Databricks для SQLTools, рабочая область Azure Databricks и локальный компьютер разработки должны соответствовать следующим требованиям.
Требования к рабочей области
У вас должна быть по крайней мере одна рабочая область Azure Databricks, и рабочая область должна соответствовать следующим требованиям:
Рабочая область должна содержать по крайней мере один Databricks SQL warehouse.
Примечание
Кластеры Azure Databricks не поддерживаются драйвером Databricks для SQLTools.
Для рабочих областей с поддержкой Unity Catalog рабочая область должна содержать по крайней мере один каталог с хотя бы одной схемой (официально называемой базой данных) в этом каталоге.
Для рабочих областей, которые не включены для Unity Catalog, рабочая область должна содержать по крайней мере одну схему (ранее называемую базой данных).
Требования к локальному компьютеру разработки
На локальном компьютере разработки необходимо иметь следующее:
- Visual Studio Code версии 1.70 или более поздней версии. Чтобы просмотреть установленную версию, щелкните Code > About Visual Studio Code в меню manin в Linux или macOS и Справка > О программе в Windows. Сведения о загрузке, установке и настройке Visual Studio Code см. в разделе Настройка Visual Studio Code.
- Расширение SQLTools для Visual Studio Code.
- Расширение Databricks Driver for SQLTools для Visual Studio Code.
Чтобы установить расширение SQLTools, перейдите к SQLTools и нажмите кнопку "Установить" или:
В Visual Studio Code щелкните Вид > Расширения в главном меню.
В поле "Поиск расширений в Marketplace" введите
SQLTools.Щелкните запись SQLTools от Matheus Teixeira.
Примечание
В списке может быть несколько записей SQLTools. Обязательно щелкните запись из Matheus Teixeira.
Щелкните Установить.
Чтобы установить расширение Databricks Driver for SQLTools, перейдите на Databricks Driver for SQLTools, а затем нажмите Установить или:
- В Visual Studio Code щелкните Вид > Расширения в главном меню.
-
В поле "Поиск расширений в Marketplace" введите
Databricks Driver for SQLTools. - Щелкните по записи Databricks Driver for SQLTools.
- Щелкните Установить.
Проверка подлинности
Необходимо настроить проверку подлинности для драйвера Databricks для SQLTools следующим образом.
Драйвер Databricks для SQLTools поддерживает следующие типы проверки подлинности Azure Databricks:
- Проверка подлинности с помощью токена личного доступа Azure Databricks
- Межмашинная аутентификация OAuth в Azure Databricks
- OAuth-аутентификация пользователь-машина (U2M) в Azure Databricks
- Аутентификация Azure CLI
Примечание
Драйвер Databricks для SQLTools не поддерживает токены Microsoft Entra ID.
Аутентификация персонального токена доступа Azure Databricks
Чтобы использовать драйвер Databricks для SQLTools с проверкой подлинности маркера личного доступа Azure Databricks, необходимо иметь личный маркер доступа Azure Databricks. Чтобы создать личный маркер доступа, выполните действия, описанные в разделе "Создание личных маркеров доступа для пользователей рабочей области".
Межмашинная аутентификация OAuth Azure Databricks (M2M)
Для аутентификации с помощью Databricks Driver for SQLTools можно использовать Azure Databricks OAuth-аутентификацию типа machine-to-machine (M2M) следующим образом:
Примечание
Проверка подлинности Azure Databricks OAuth M2M доступна в Databricks Driver for SQLTools версии 0.4.2 и выше.
- Выполните действия по настройке для аутентификации OAuth M2M. См. сведения о аутентификации OAuth machine-to-machine (M2M).
- Создайте профиль конфигурации Azure Databricks с параметрами конфигурации аутентификации OAuth M2M. См. раздел «Config» в аутентификации OAuth между машинами (M2M).
- Установите и откройте расширение Databricks для Visual Studio Code на локальном компьютере разработки.
- В расширении Databricks IDE нажмите кнопку Configure в панели Configuration . Если кнопка "Настроить" не отображается, щелкните значок шестеренки (Настроить рабочую область).
- В палитре команд для Хост Databricks введите URL-адрес Azure Databricks для отдельной рабочей области, например
https://adb-1234567890123456.7.azuredatabricks.net, и нажмите клавишу Enter. - Выберите запись профиля конфигурации, соответствующую созданной на шаге 2.
- Выполните инструкции на экране в веб-браузере, чтобы завершить аутентификацию в учетной записи Azure Databricks.
Аутентификация OAuth пользователь-компьютер (U2M) в Azure Databricks
Для аутентификации с помощью драйвера Databricks для SQLTools можно использовать OAuth-аутентификацию Azure Databricks "пользователь-машина" (U2M), как указано ниже:
Примечание
Проверка подлинности OAuth U2M Azure Databricks доступна в Databricks Driver for SQLTools версии 0.4.2 и выше.
- Установите и откройте расширение Databricks для Visual Studio Code на локальном компьютере разработки.
- В расширении Databricks IDE нажмите кнопку Configure в панели Configuration . Если кнопка «Настройка» не отображается, щелкните значок шестеренки (Настройка рабочей области).
- В палитре команд в поле хоста Databricks введите URL-адрес Azure Databricks для конкретной рабочей области, например
https://adb-1234567890123456.7.azuredatabricks.net. Затем нажмите Enter. - Выберите OAuth (пользователь — машина).
- Выполните инструкции на экране в веб-браузере, чтобы завершить аутентификацию в учетной записи Azure Databricks. Если появится запрос, разрешите доступ
all-apis.
Проверка подлинности Azure CLI
Azure CLI можно использовать для аутентификации с помощью драйвера Databricks для SQLTools, как показано ниже.
Примечание
Проверка подлинности с помощью Azure CLI имеет статус экспериментальной функции. Эта функция доступна в Databricks Driver for SQLTools версии 0.4.2 и выше.
- Установите Azure CLI на локальном компьютере разработки, если это еще не сделано.
- Установите и откройте расширение Databricks для Visual Studio Code на локальном компьютере разработки.
- В расширении Databricks IDE нажмите кнопку Configure в панели Configuration . Если кнопка «Настройка» не отображается, щелкните значок шестеренки (настройка рабочей области).
- В палитре команд в поле Хост Databricks введите URL-адрес Azure Databricks для рабочей области, например
https://adb-1234567890123456.7.azuredatabricks.net. Нажмите клавишу Enter. - Выберите Azure CLI.
- Следуйте инструкциям на экране, чтобы завершить проверку подлинности с помощью Azure CLI.
Подключение к схеме
В Visual Studio Code на боковой панели щелкните значок SQLTools.
В представлении SQLTools, если вы впервые используете расширение SQLTools, нажмите Добавить новое подключение в области Подключения. В противном случае щелкните значок "Добавить новое подключение" в строке заголовка панели.
На вкладке «Параметры SQLTools» на шаге «Выберите драйвер базы данных» щелкните значок Databricks.
На шаге "Параметры подключения " введите следующие сведения о хранилище, каталоге и схеме:
- В поле "Имя подключения" введите уникальное имя для этого подключения.
- (Необязательно) Для группы подключений введите имя существующей группы подключений, чтобы добавить новое подключение к этой группе. Или введите уникальное имя, чтобы создать новую группу соединений с новым подключением. Группы подключений упрощают поиск подключений в расширении.
- Для подключения, используя выберите один из следующих вариантов:
- Чтобы использовать личный маркер доступа Azure Databricks для проверки подлинности, выберите Hostname and Token.
- Для Databricks Driver for SQLTools версий 0.4.2 и выше для использования проверки подлинности OAuth U2M или M2M или Azure CLI выберите расширение VS Code (бета-версия).
Если вы выбрали имя узла и токендля подключения, то для узла введите параметр имени узла хранилища. Чтобы получить параметр имени сервера хранилища, см. сведения о подключении для вычислительного ресурса Azure Databricks.
В поле Path введите параметр HTTP-пути хранилища или кластера. Чтобы получить параметры HTTP-пути хранилища, см. статью «Получение сведений о подключении для вычислительного ресурса Azure Databricks».
Если вы выбрали Hostname и Token в поле Способ подключения, введите значение токена личного доступа Azure Databricks в Token.
Для Каталог введите имя каталога.
Примечание
Для рабочих областей, которые не включены для Unity Catalog, можно оставить поле Catalog пустым, чтобы использовать значение
hive_metastoreпо умолчанию.Для Schema введите имя схемы.
(Необязательно) Для параметра "Показать записи по умолчанию" оставьте значение по умолчанию
50, чтобы показывать только первые 50 строк для каждого запроса, или введите другое ограничение.
Нажмите кнопку Проверить подключение.
Если тест подключения выполнен успешно, нажмите кнопку "Сохранить подключение".
Изменение параметров подключения
Эта процедура предполагает, что вы успешно подключены как минимум к одному хранилищу.
- Если представление SQLTools не отображается, в Visual Studio Code на боковой панели щелкните значок SQLTools.
- В области \"Подключения\" разверните группу подключений, если она существует для целевого подключения.
- Щелкните правой кнопкой мыши подключение и выберите команду "Изменить подключение".
- Измените целевые параметры.
- Нажмите Проверить подключение.
- Если тест подключения выполнен успешно, нажмите кнопку Сохранить подключение.
Просмотр объектов схемы
- В области «Подключения» разверните группу подключений, если она существует для целевого подключения.
- Дважды щелкните или разверните целевое подключение вашего хранилища.
- Раскройте целевую базу данных (схему), если она существует для вашего подключения.
- Разверните таблицы или представления, если для базы данных (схема) существует одна или несколько таблиц или представлений.
- Разверните любую целевую таблицу или представление, чтобы просмотреть столбцы таблицы или представления.
Просмотреть строки или схему таблицы или представления
При развернутых таблицах или представлениях в области "Подключения" выполните одно из следующих действий:
- Чтобы отобразить строки таблицы или представления, щелкните правой кнопкой мыши таблицу или представление и выберите команду "Показать записи таблицы " или "Показать записи представления".
- Чтобы отобразить схему таблицы или представления, щелкните правой кнопкой мыши таблицу или представление и нажмите кнопку "Описать таблицу " или "Описать представление".
Создайте запрос INSERT для таблицы
- Поместите курсор в открытый редактор в то место, куда нужно добавить Insert-запрос.
- При развернутом узле Таблицы в области "Подключения" щелкните таблицу правой кнопкой мыши и выберите Сгенерировать запрос INSERT. Определение запроса вставки добавляется в точку вставки курсора.
Создание и запуск запроса
В этой процедуре предполагается, что вы успешно подключены как минимум к одному складу.
- В области "Подключения" разверните группу подключений, если она существует для целевого подключения.
- Дважды щелкните или разверните целевое подключение вашего хранилища.
- При выбранном подключении нажмите кнопку "Создать SQL-файл " в строке заголовка области "Подключения ". Откроется новая вкладка редактора.
- Введите SQL-запрос в новом редакторе.
- Чтобы запустить SQL-запрос, нажмите кнопку «Выполнить для активного подключения» в редакторе. Результаты запроса отображаются на новой вкладке редактора.
Запустить существующий запрос
В этой процедуре предполагается, что вы успешно подключены как минимум к одному складу.
- В области "Подключения" разверните группу подключений, если она существует для целевого подключения.
- Дважды щелкните или разверните целевое подключение для склада.
- При выбранном подключении откройте любой файл с расширением
.sqlили выберите любую группу непрерывных инструкций SQL в любом открывшемся ранее редакторе. - Чтобы запустить SQL-запрос из открытого
.sqlфайла, с содержимым.sqlфайла, отображаемым в редакторе, нажмите Запустить на активном подключении в редакторе. Результаты запроса отображаются на новой вкладке редактора. - Чтобы запустить выбранную группу непрерывных SQL-операторов в ранее открытом редакторе, щелкните правой кнопкой мыши выделенный фрагмент, а затем нажмите Выполнить выбранный запрос. Результаты запроса отображаются на новой вкладке редактора.
Отправить журналы использования в Databricks
Если при использовании драйвера Databricks для SQLTools возникают проблемы, вы можете отправить журналы использования и связанные сведения в службу поддержки Databricks, выполнив следующие действия:
- Установите расширение Databricks для Visual Studio Code на локальном компьютере разработки.
- Включите логирование, проверив настройку Logs: Enabled или установив
databricks.logs.enabledзначениеtrue, как описано в настройках расширения Databricks IDE. Обязательно перезапустите Visual Studio Code после включения логирования. - Попытайтесь воспроизвести вашу проблему.
- Из Палитры команд (Вид > Палитра команд в главном меню) выполните команду Databricks: Open full logs.
- Отправьте файлы
Databricks Logs.log,databricks-cli-logs.jsonиsdk-and-extension-logs.json, которые отображаются в службе поддержки Databricks. - Кроме того, скопируйте содержимое Терминала (Вид Терминал) в контексте проблемы и отправьте это содержимое в службу поддержки Databricks.
Представление Вывод (Вид > Вывод, журналы Databricks) отображает усеченные сведения, если установлен флажок Logs: Enabled или имеет значение . Для получения дополнительной информации измените следующие настройки, как описано в разделе Настройки расширения Databricks IDE:
-
Журналы: Макс. длина массива или
databricks.logs.maxArrayLength -
Журналы: Макс. длина поля или
databricks.logs.maxFieldLength -
Журналы: глубина усечения или
databricks.logs.truncationDepth