Примечание.
Для доступа к этой странице требуется авторизация. Вы можете попробовать войти или изменить каталоги.
Для доступа к этой странице требуется авторизация. Вы можете попробовать изменить каталоги.
В этой статье описывается, как установить и открыть расширение Databricks IDE, а затем настроить проект для использования этого расширения. См. расширение Databricks IDE.
Требования
Чтобы использовать расширение Databricks IDE:
У вас должна быть хотя бы одна рабочая область Azure Databricks, а рабочая область должна содержать по крайней мере один кластер Azure Databricks. Если у вас нет доступного кластера, вы можете создать кластер при установке расширения Databricks IDE.
Примечание.
Хранилища SQL Databricks не поддерживаются этим расширением.
У вас должен быть установлен Visual Studio Code версии 1.104.0 или выше. Чтобы просмотреть установленную версию, щелкните Code > About Visual Studio Code в главном меню в Linux или macOS и Help > About в Windows. Сведения о скачивании, установке и настройке Visual Studio Code см. в разделе Setting up Visual Studio Code.
Visual Studio Code необходимо настроить для написания кода Python, включая доступность интерпретатора Python. Дополнительные сведения см. в статье Getting Started with Python in VS Code.
Установка и открытие расширения
В Visual Studio Code откройте представление Extensions (View > Extensions в главном меню).
В разделе "Расширения поиска" в Marketplace введите Databricks.
Щелкните расширение Databricks и нажмите кнопку "Установить".
Примечание.
Обязательно выберите расширение, которое является проверенным владельцем Databricks .
Щелкните Reload Required или перезапустите Visual Studio Code.
(По желанию) Когда вас запросят, устанавливайте AI-инструменты, чтобы ваши агенты для программирования эффективно работали с Azure Databricks. См. «Установить и использовать AI-инструменты».
Чтобы открыть расширение, на боковой панели щелкните значок Databricks .
Настройте расширение Databricks IDE для подключения к вашему рабочему пространству Azure Databricks. См. «Настроить проект Databricks».
Установка другой версии расширения
Если вы хотите установить определённую версию расширения Databricks IDE, например, предыдущую, или обновить до версии релиза, в Visual Studio Code в представлении "Extensions" (Просмотр > расширений из главного меню):
Щелкните Databricks, а затем щелкните стрелку раскрывающегося списка "Удалить ".
Нажмите кнопку "Установить другую версию " и выберите версию.
Кроме того, чтобы обновить версию выпуска, нажмите кнопку "Переключиться на версию выпуска".
Чтобы применить изменение версии, щелкните Restart Extensions или перезапустите Visual Studio Code.
Дополнительные сведения см. в документации по расширению Visual Studio Code.
Удаление расширения
Если вам нужно удалить расширение Databricks IDE, в Visual Studio Code нажмите Вид > Расширения в главном меню, затем:
- В списке расширений выберите расширение Databricks .
- Нажмите кнопку Удалить.
- Щелкните Reload Required или перезапустите Visual Studio Code.