Сценарий. Ошибка watchdog: BUG: soft lockup — CPU в кластере Azure HDInsight

В этой статье описаны действия по устранению неполадок и возможные способы решения проблем при взаимодействии с кластерами Azure HDInsight.

Проблема

В системных журналах ядра содержится сообщение об ошибке: watchdog: BUG: soft lockup - CPU.

Причина

Ошибка в ядре Linux вызывает мягкую блокировку ЦП.

Решение

Примените исправление ядра. Приведенный ниже скрипт обновляет ядро Linux и перезагружает компьютеры в разное время за период в 24 часа. Выполните действие этого скрипта в два подхода. Первое выполнение — на всех узлах, кроме головного узла. Второе выполнение — на головном узле. Не запускайте его одновременно на головном узле и других узлах кластера.

  1. Перейдите к кластеру HDInsight на портале Azure.

  2. Перейдите к действиям скрипта.

  3. Щелкните Отправить новое и введите входные данные, как показано ниже.

    Свойство Значение
    Тип скрипта -Custom
    Имя Исправление проблемы ядра, приводящей к мягкой блокировке
    URI bash-скрипта https://raw.githubusercontent.com/hdinsight/hdinsight.github.io/master/ClusterCRUD/KernelSoftLockFix/scripts/KernelSoftLockIssue_FixAndReboot.sh
    Типы узлов Worker, Zookeeper
    Параметры Н/Д

    При необходимости выберите Сохранить этот скрипт для повторного выполнения при добавлении новых узлов в кластер.

  4. Щелкните Создать.

  5. Дождитесь, пока завершится выполнение.

  6. Выполните действие скрипта на головном узле, повторив процесс из шага 3, указав типы узлов Head.

  7. Дождитесь, пока завершится выполнение.

Дальнейшие действия

Если вы не видите своего варианта проблемы или вам не удается ее устранить, дополнительные сведения можно получить, посетив один из следующих каналов.

  • Получите ответы специалистов Azure на сайте поддержки сообщества пользователей Azure.

  • Подпишитесь на @AzureSupport — официальный канал Microsoft Azure для улучшения качества взаимодействия с клиентами. Вступайте в сообщество Azure для получения нужных ресурсов: ответов, поддержки и советов экспертов.

  • Если вам нужна дополнительная помощь, отправьте запрос в службу поддержки на портале Azure. Выберите Поддержка в строке меню или откройте центр Справка и поддержка. Дополнительные сведения см. в статье Создание запроса на поддержку Azure. Доступ к управлению подписками и поддержкой выставления счетов уже включен в вашу подписку Microsoft Azure, а техническая поддержка предоставляется в рамках одного из планов Службы поддержки Azure.