Примечание
Для доступа к этой странице требуется авторизация. Вы можете попробовать войти или изменить каталоги.
Для доступа к этой странице требуется авторизация. Вы можете попробовать изменить каталоги.
В этой статье описаны действия по устранению неполадок и возможные способы решения проблем при взаимодействии с кластерами Azure HDInsight.
Проблема
Служба REST Apache HBase не отвечает на запросы в Azure HDInsight.
Причина
Это может быть связано с утечкой сокетов в службе REST для Apache HBase. Чаще всего такое случается при длительной работе службы (например, в течение нескольких месяцев). В клиентском пакете SDK может появиться следующее сообщение об ошибке:
System.Net.WebException : Unable to connect to the remote server --->
System.Net.Sockets.SocketException : A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond 10.0.0.19:8090
Разрешение
Перезапустите REST HBase, выполнив следующую команду, выполнив SSH-подключение к узлу. Вы также можете использовать действия скрипта, чтобы перезапустить эту службу на всех рабочих узлах:
sudo /usr/hdp/current/hbase-master/bin/hbase-daemon.sh restart rest
Если проблема сохраняется, можно установить следующий скрипт устранения рисков в качестве задания CRON, которое выполняется каждые 5 минут на каждом рабочем узле. Этот скрипт устранения рисков проверяет связь со службой REST и перезапускает ее, если служба REST не отвечает.
#!/bin/bash
nc localhost 8090 < /dev/null
if [ $? -ne 0 ]
then
echo "RESTServer is not responding. Restarting"
sudo /usr/hdp/current/hbase-regionserver/bin/hbase-daemon.sh restart rest
fi
Следующие шаги
Если вы не нашли вашу проблему или не можете ее решить, для получения дополнительной поддержки посетите один из следующих каналов.
Получите ответы специалистов Azure на сайте поддержки сообщества пользователей Azure.
Подпишитесь на @AzureSupport — официальный канал Microsoft Azure для улучшения качества взаимодействия с клиентами. Вступайте в сообщество Azure для получения нужных ресурсов: ответов, поддержки и советов экспертов.
Если вам нужна дополнительная помощь, отправьте запрос в службу поддержки на портале Azure. Выберите Поддержка в строке меню или откройте центр Справка и поддержка. Дополнительные сведения см. в статье Создание запроса на поддержку Azure. Доступ к управлению подписками и поддержкой выставления счетов уже включен в вашу подписку Microsoft Azure, а техническая поддержка предоставляется в рамках одного из планов Службы поддержки Azure.