Примечание.
Для доступа к этой странице требуется авторизация. Вы можете попробовать войти или изменить каталоги.
Для доступа к этой странице требуется авторизация. Вы можете попробовать изменить каталоги.
С помощью Power BI Desktop вы можете подключиться к миру данных, создать убедительные и базовые отчеты, а также поделиться своими усилиями с другими пользователями, которые затем смогут опираться на вашу работу и расширить свои усилия по бизнес-аналитике.
Просмотры Power BI Desktop
Power BI Desktop имеет три представления:
- Представление отчета — вы можете использовать запросы, которые вы создаете для создания убедительных визуализаций, упорядоченные так, как вы хотите, чтобы они отображались, и состоящие из нескольких страниц, которыми вы можете поделиться с другими.
- представление таблицы — просмотр данных в отчете в формате модели данных, в котором можно добавлять вычисления, создавать новые столбцы и управлять связями.
- Представление модели — получение графического представления связей, установленных в модели данных, и управление ими при необходимости.
Для доступа к этим представлениям выберите один из трех значков в левой части Power BI Desktop. На следующем рисунке выбрано представление отчета , указанное желтой полосой рядом с значком.
Power BI Desktop также поставляется с Редактором Power Query. Используйте Редактор Power Query для подключения к одному или нескольким источникам данных, формирования и преобразования данных в соответствии с вашими потребностями, а затем загрузите его в Power BI Desktop.
В этой статье представлен обзор работы с данными в Редакторе Power Query, но есть еще много, чему можно научиться. В конце этой статьи вы найдете ссылки на подробные рекомендации по поддерживаемым типам данных. Вы также найдете рекомендации по подключению к данным, формированию данных, созданию связей и началу работы.
Давайте сначала познакомимся с Редактором Power Query.
Редактор Power Query
Power BI Desktop предлагает два интерфейса Редактор Power Query:
- Новый интерфейс Power Query (предварительная версия): переработанный редактор с упрощенной навигацией, улучшенной доступностью и единообразным интерфейсом Power Query в Power BI Desktop, средстве веб-моделирования и других продуктах Fabric.
- Прежний интерфейс: исходное окно редактора Power Query.
В обоих случаях вы используете редактор Power Query для подключения к одному или нескольким источникам данных, настройки и преобразования данных в соответствии с вашими потребностями, а затем загружаете результат в Power BI Desktop. Выберите вкладку, соответствующую используемому интерфейсу.
Сведения об известных ограничениях, способах их обхода и о том, где можно оставить отзыв, см. в статье Известные ограничения и обходные пути нового интерфейса Power Query.
Замечание
Новый интерфейс Power Query доступен в предварительной версии.
Необходимые условия
Power BI Desktop с включенной функцией предварительного просмотра New Power Query.
Чтобы включить новый интерфейс Power Query, выполните следующие действия.
- Запустите Power BI Desktop.
- Перейдите к Файл>Параметры и настройки>Параметры.
- Выберите функции предварительного просмотра Preview features, а затем установите флажок новый интерфейс Power Query.
- Нажмите ОК.
Одна и та же предварительная версия включает как новый интерфейс получения данных, так и новый Редактор Power Query. Чтобы вернуться в устаревший редактор, снимите флажок. Вам не нужно перезапустить Power BI Desktop. Дополнительные сведения о новом интерфейсе получения данных см. в статье "Получение данных" в Power BI Desktop.
Откройте редактор Power Query
Чтобы открыть Редактор Power Query, выберите "Преобразовать данные" на вкладке "Главная" Power BI Desktop.
Без подключений к данным Редактор Power Query отображается как пустая панель, готовая к данным. После загрузки запроса редактор представляет пять отдельных компонентов. Числа в следующей таблице соответствуют нумерованным выноскам на снимке экрана.
| # | Компонент | Description |
|---|---|---|
| 1 | Лента | Интерфейс навигации ленты, который предоставляет несколько вкладок для добавления преобразований, выбора параметров запроса и доступа к различным кнопкам ленты для выполнения различных задач. |
| 2 | Область запросов | Просмотр всех доступных вам запросов. |
| 3 | Текущее представление | Основное рабочее представление, которое по умолчанию отображает предварительный просмотр данных для запроса. Вы также можете включить представление схемы вместе с предварительным просмотром данных. Вы можете переключаться между представлением схемы и предварительным просмотром данных при сохранении представления схемы. |
| 4 | Параметры запроса | Представление выбранного в данный момент запроса с соответствующими сведениями, такими как имя запроса, шаги запроса и различные индикаторы. |
| 5 | Строка состояния | На панели отображаются важные сведения о запросе, например время выполнения, общее количество столбцов и строк, а также состояние обработки. Эта панель также содержит кнопки для изменения текущего представления. |
Каждый из этих компонентов описан в следующих разделах. Полное пошаговое руководство по пользовательскому интерфейсу Power Query см. в разделе "Использование Power Query для преобразования данных".
Лента
Лента — это компонент, в котором вы найдете большую часть преобразований и действий, которые можно выполнить в Редактор Power Query. Команды группируются на вкладках "Главная", "Преобразование", " Добавить столбец", "Вид", "Инструменты" и "Справка ". Каждая вкладка предоставляет определенные кнопки и параметры, которые позволяют легко получить доступ к преобразованиям и действиям, которые могут потребоваться.
Вкладка "Главная " содержит распространенные задачи запроса, включая команды получения данных , которые используются для подключения к данным и запуска процесса создания запроса. Дополнительные сведения о доступных источниках данных см. в разделе "Источники данных" в Power BI Desktop. Дополнительные сведения об использовании соединителей см. в статье Обзор получения данных.
Вкладка "Преобразование" предоставляет доступ к общим задачам преобразования данных, таким как добавление или удаление столбцов, изменение типов данных и разделение столбцов. Вкладка "Добавить столбец " предоставляет дополнительные задачи, связанные с добавлением столбца, форматированием данных столбцов и добавлением настраиваемых столбцов. Вкладка Вид определяет, какие области и представления отображаются, а также открывает Расширенный редактор.
Интерфейс Power Query реагирует и настраивается на разрешение экрана. Если требуется компактная версия ленты, нажмите кнопку свернуть в правом нижнем углу ленты. Чтобы вернуться к стандартной ленте, щелкните значок развертывания в том же углу.
Многие задачи, доступные на ленте, также доступны, щелкнув правой кнопкой мыши столбец или другие данные в текущем представлении. Преобразования часто можно достичь из нескольких мест, поэтому вы можете использовать предпочитаемую возможность.
Дополнительные сведения о преобразовании данных, включая примеры, см. в руководстве по созданию фигур и объединении данных в Power BI Desktop.
Область "Запросы"
На панели "Запросы" отображаются все доступные запросы. При выборе запроса его данные отображаются в текущем представлении, где можно формировать и преобразовывать данные в соответствии с вашими потребностями.
Щелкните значок в правом верхнем углу области "Запросы ", чтобы свернуть панель, и снова выберите ее, чтобы развернуть область. Аналогичные значки в интерфейсе позволяют свернуть или развернуть другие представления и разделы, чтобы сосредоточиться на представлении, которое наиболее важно для вас.
Дополнительные сведения см. в области "Запросы".
Текущий вид
Текущий вид — это ваш основной рабочий вид. По умолчанию отображается предварительный просмотр данных для выбранного запроса. Здесь вы выполняете большую часть работы с запросами. Выберите заголовок столбца или щелкните его правой кнопкой мыши, чтобы просмотреть преобразования, доступные для этого столбца. Многие из этих элементов такие же, как кнопки на вкладках ленты.
При выборе преобразования запрос применяет этот шаг к данным. Он также сохраняет шаг как часть самого запроса. Панель параметров запроса записывает шаги последовательного порядка, как описано далее в этой статье.
Вы также можете включить средства профилирования данных, чтобы лучше понять данные, включая распределение значений и качество столбцов. Включите и отключите эти средства на вкладке "Вид " в удобном режиме. Дополнительные сведения см. в разделе "Использование средств профилирования данных".
Переключение между режимами
Помимо свертывание панелей и разделов, можно также переключать отображаемые представления. Перейдите на вкладку "Вид " на ленте, где находятся группы предварительного просмотра и макета , которые управляют тем, как выглядит интерфейс.
В правой части строки состояния также содержатся значки для представления диаграмм, данных и схемы. Используйте эти значки для изменения между представлениями или включения и отключения выбранного представления.
Попробуйте использовать эти параметры, чтобы найти представление и макет, с которыми вы наиболее комфортно работаете.
Просмотр схемы
Представление схемы обеспечивает быстрый и простой способ взаимодействия только с компонентами схемы для таблицы, такими как имена столбцов и типы данных. Используйте представление схемы, если требуется выполнить действия, связанные с схемой, например удаление столбцов, переименование столбцов, изменение типов данных столбцов, изменение порядка столбцов или дублирование столбцов.
Если представление схемы активно, вкладка "Средства схемы " отображается на ленте с действиями, которые применяются к столбцам.
Дополнительные сведения см. в разделе "Использование представления схемы".
Вид диаграммы
Представление схемы помогает визуализировать структуру запроса и способ взаимодействия с другими запросами в проекте. Каждый шаг в запросе имеет отдельный значок, помогающий распознавать используемое преобразование, и строки подключают шаги для иллюстрации зависимостей.
Если включен просмотр данных и представление диаграммы, представление схемы отображается в верхней части предварительного просмотра данных. С включенным представлением схемы выберите знак "плюс", чтобы найти новое преобразование, чтобы добавить в запрос.
Дополнительные сведения см. в представлении диаграммы.
Область параметров запроса
В области параметров запроса отображаются сведения о выбранном запросе, например имени запроса, его шагах и различных индикаторах. Каждое преобразование, примененное к запросу, сохраняется как шаг в разделе "Примененные шаги ".
Если вам нужно проверить, как ваш запрос преобразуется с шага на шаг, выберите шаг, чтобы просмотреть способ разрешения запроса в этой конкретной точке.
Важно знать, что базовые данные не изменяются. Скорее, Редактор Power Query настраивает и формирует представление данных.
Вы можете переименовывать, удалять и менять порядок шагов по своему усмотрению. Для этого щелкните правой кнопкой мыши шаг в разделе "Примененные шаги " и выберите в появившемся меню. Выберите свойства , чтобы изменить имя шага или добавить в него описание. Все шаги запроса выполняются в том порядке, в который они отображаются.
Дополнительные сведения см. в разделе "Использование списка примененных шагов".
Строка состояния
Строка состояния отображается в нижней части редактора и отображает важные сведения о запросе, например время выполнения, общее количество столбцов и строк, а также состояние обработки. В правой части строки состояния также содержатся значки, которые можно использовать для изменения текущего представления.
Строка формул
На панели формул показано выражение языка формулы Power Query M для выбранного шага. Выражение можно изменить непосредственно в строке формул, чтобы настроить один шаг или использовать Расширенный редактор для работы с полным скриптом запроса.
Получите помощь
Вкладка справки в Редактор Power Query содержит ссылки на Power BI сведения. Вы можете открыть те же параметры справки, выбрав Файл>.
Расширенный редактор
Расширенный редактор позволяет увидеть код, который Редактор Power Query создает с каждым шагом. Он также позволяет создать собственный код на языке формул Power Query M. Чтобы запустить расширенный редактор, выберите "Вид" на ленте, а затем выберите Расширенный редактор. Откроется окно с кодом, созданным для выбранного запроса.
Вы можете напрямую изменить код в окне Расширенный редактор. Чтобы закрыть окно, нажмите кнопку "Готово " или "Отменить ".
Расширенный редактор доступен как в новом, так и в устаревшем интерфейсе. На предыдущем снимка экрана показан устаревший интерфейс. Некоторые элементы управления Расширенный редактор и параметры отображения отличаются в новом интерфейсе. Дополнительные сведения см. в статье о известных ограничениях и обходных решениях для новых Power Query.
Сохранение работы
Когда запрос расположен в нужном месте, выберите "Закрыть и применить" из меню "Файл" Редактора Power Query. Это действие применяет изменения и закрывает редактор.
По мере выполнения процесса Power BI Desktop предоставляет диалоговое окно, чтобы показать его статус.
Когда вы будете готовы, Power BI Desktop может сохранить работу в виде PBIX-файла .
Чтобы сохранить вашу работу, выберите Файл>Сохранить (или Файл>Сохранить как), как показано на следующем рисунке.
Связанный контент
Есть все виды действий, которые можно сделать с помощью Power BI Desktop. Дополнительные сведения о его возможностях см. в следующих ресурсах:
- Что такое Power BI?
- Преобразование данных с помощью Power Query
- Известные ограничения и обходные пути нового интерфейса Power Query
- Data sources in Power BI Desktop (Источники данных в Power BI Desktop)
- Подключение к источникам данных в Power BI Desktop
- Руководство. Формирование и объединение данных с Power BI Desktop
- Выполнение распространенных задач запросов в Power BI Desktop