Устранение неполадок с электронной почтой
Эта статья поможет вам устранить неполадки, связанные с электронной почтой в Dynamics 365 Sales.
Проблема 1. Редактор Email отображает неправильный заголовок во всплывающем окне контекстного сообщения электронной почты
После обновления до Dynamics 365 2020 волны выпуска 2 редактор электронной почты отображает неправильный заголовок во всплывающем окне контекстного сообщения.
Причина
Для готовых форм электронной почты активируются события и onchange
, onload
что помогает обновить название электронной почты и другие атрибуты во всплывающем окне контекстного сообщения. Если у вас есть настраиваемая форма электронной почты или форма неуправляемого слоя, onload
события и onchange
будут недоступны. Поэтому заголовок сообщения электронной почты отображается неправильно.
Разрешение
Чтобы устранить эту проблему, необходимо добавить события и onchange
в onload
настраиваемые формы электронной почты.
Добавьте настраиваемую форму электронной почты в созданное решение.
Добавьте следующий код в XML-код формы:
<events> <event name="onload" application="true" active="true"> <InternalHandlers> <Handler functionName="Activities.Email.formOnload" libraryName="Activities/SystemLibraries/Email_main_system_library.js" handlerUniqueId="ecdfe4d8-d6d3-4d21-ab68-8ea75bb30a79" enabled="true" parameters="" passExecutionContext="true" /> <Handler functionName="Activities.Email.NotifyPanelSubjectChange" libraryName="Activities/SystemLibraries/Email_main_system_library.js" handlerUniqueId="{706607A8-4424-4C9A-847A-602FC8035B48}" enabled="true" parameters="" passExecutionContext="true" solutionaction="Added"/> </InternalHandlers> </event> <event name="onchange" application="true" active="true" attribute="subject" solutionaction="Added"> <Handlers> <Handler functionName="Activities.Email.NotifyPanelSubjectChange" libraryName="Activities/SystemLibraries/Email_main_system_library.js" handlerUniqueId="{706607A8-4424-4C9A-847A-602FC8035B48}" enabled="true" parameters="" passExecutionContext="true"/> </Handlers> </event> </events> <clientresources> <internalresources> <clientincludes> <internaljscriptfile src="$webresource:Activities/SystemLibraries/Email_main_system_library.js" /> </clientincludes> </internalresources> </clientresources>
Проблема 2. Не удается просмотреть неотслеченные сообщения электронной почты и собрания при автоматическом захвате
При автоматическом захвате не отображаются неотслеживаемые сообщения электронной почты и собрания для некоторых или всех пользователей в организации.
Причина
Начиная с версии 9.2.24031.00102, Dynamics 365 Sales следует принципу доступа с минимальными привилегиями, который запрещает пользователям с политиками условного доступа для своих клиентов доступ к неотслеченным сообщениям электронной почты и собраниям.
Если пользователь не может видеть неотслеченные сообщения электронной почты и собрания, выполните следующие действия, чтобы проверить, вызвана ли проблема политикой условного доступа.
Войдите в Центр администрирования Microsoft Entra как минимум администратор условного доступа.
Перейдите в раздел Мониторинг удостоверений> &журналы входа всистему работоспособности>.
Перейдите на вкладку Входы пользователей (неинтерактивные) и добавьте следующие фильтры:
- Приложение содержит Dataverse
- Ресурс содержит Microsoft Graph
- Состояние равно Сбою
Если для затронутых пользователей возвращаются некоторые результаты, проблема связана с политикой условного доступа.
Обходной путь
Решение этой проблемы отсутствует, так как это ожидаемое поведение. В качестве альтернативы пользователи могут использовать Microsoft Copilot for Sales в Outlook для записи отдельных действий или использовать синхронизацию на стороне сервера для автоматического отслеживания всех сообщений электронной почты и собраний.