Ошибка 0x00000709 при использовании записи CNAME для сервера печати в Windows Server 2008 R2: не удалось завершить операцию

Эта статья поможет устранить ошибку 0x00000709 (не удалось завершить операцию). Ошибка возникает при использовании записи CNAME для сервера печати.

Применяется к: Windows Server 2012 R2
Исходный номер базы знаний: 2546625

Симптомы

Рассмотрим следующий сценарий.

  • У вас есть принтеры, размещенные в системе под управлением Windows Server 2008 R2.
  • Вы предоставляете альтернативный UNC-путь для сервера печати. И вы решили сделать это, используя запись ресурса CNAME (псевдоним) в DNS.
  • Клиенты пытаются подключиться к принтерам с помощью записи CNAME в пути UNC.

В этом сценарии клиенты не могут подключаться к принтерам, если они используют запись CNAME в пути UNC. Кроме того, попытки подключения к общим принтерам завершаются ошибкой:

Не удалось завершить операцию (ошибка 0x00000709). Дважды проверка имя принтера и убедитесь, что принтер подключен к сети.

Примечание.

Причина

Эта проблема может возникнуть, если некоторые решения DNS сторонних разработчиков обеспечивают разрешение имен для сети.

Разрешение

Чтобы обойти эту проблему, выполните следующие действия на сервере печати, а затем перезапустите службу очереди печати:

  1. DnsOnWire Реализуйте значение реестра, описанное в следующей статье:

    Сообщение об ошибке при попытке подключиться к принтеру с помощью записи ресурса псевдонима (CNAME): "Windows не удалось подключиться к принтеру"

  2. Измените локальный файл Hosts, включив запись CNAME для сервера.

    Примечание.

    Запись файла Hosts должна быть введена как имя NetBIOS, а не как полное доменное имя.

Следующий пример предназначен только для иллюстрации. Используйте имена и IP-адреса, допустимые для вашей сети.

Использовать имя NetBIOS: 192.168.0.10 CNAME

Не используйте полное доменное имя: 192.168.0.10 CNAME.CONTOSO.COM

Дополнительная информация

Проблема, описанная в разделе "Симптомы" , может возникнуть, если решение DNS сторонних поставщиков предоставляет QRecord ответы типа ALL.

Сбор данных

Если вам нужна помощь со стороны службы поддержки Майкрософт, рекомендуем собрать информацию, выполнив действия, описанные в статье Сбор информации с помощью TSS для проблем с взаимодействием с пользователем.