Поделиться через


Сообщение об ошибке "Занято сервером" при попытке сканирования документа

В этой статье описано разрешение ошибки "Занято сервером" при попытке сканирования документа.

Применяется к: Windows 10 — все выпуски
Исходный номер базы знаний: 2971655

Симптомы

Рассмотрим следующий сценарий:

  • Вы используете 64-разрядную версию Windows 8.1, Windows 8 или Windows 7.
  • Выполняется 32-разрядное приложение сканирования.
  • Вы используете сканер, использующий интерфейс TWAIN 1.0 по умолчанию.
  • Вы пытаетесь проверить документ.

В этом сценарии появится сообщение "Что нужно сканировать?". В окне сообщения также отображаются параметры настройки сканера. Через несколько секунд вы получите следующее сообщение об ошибке:

Сервер занят.

Причина

Эта проблема возникает, так как 32-разрядное приложение сканирования работает в 64-разрядной версии Windows. В этой ситуации драйверы для сканера загружаются во время отдельного процесса Wiawow64.exe. Сообщение "Что вы хотите сканировать?", является частью процесса Wiawow64. Сообщение об ошибке вызвано вызовом OLE из 32-разрядного приложения сканирования. Эта проблема возникает из-за того, что вызов OLE имеет значение времени ожидания ввода пользователем в окне "Что нужно проверить?".

Решение

Чтобы устранить эту проблему, рекомендуется обратиться к поставщику приложения сканирования, чтобы обновить приложение.

Дополнительная информация

Если вы являетесь разработчиком, ознакомьтесь со следующими сведениями:

При вызове AfxOleInit(); Функция, параметр m_nTimeout имеет значение по умолчанию в 8 секунд. Чтобы отключить время ожидания вызова OLE, необходимо добавить следующую строку после вызова AfxOleInit(); функция:

AfxOleGetMessageFilter()->EnableNotRespondingDialog(FALSE);

Сбор данных

Если вам нужна помощь от поддержки Майкрософт, рекомендуется собирать сведения, выполнив действия, описанные в статье "Сбор сведений" с помощью TSS для проблем с взаимодействием с пользователем.