Поделиться через


Фильтры групповой политики WMI, сравнивающие Win32_OperatingSystem BuildNumber, не работают должным образом.

В этой статье описывается решение проблемы, из-за которой фильтры групповой политики инструментария управления Windows (WMI), сравнивающие Win32_OperatingSystem BuildNumber, не работают должным образом в Windows 10.

Применяется к: Windows 10 — все выпуски
Исходный номер базы знаний: 3119213

Симптомы

Рассмотрим следующий сценарий:

  • Вы хотите применить групповую политику к Windows 8.1 и более поздним версиям Windows.

  • Для этого необходимо использовать Win32_OperatingSystem BuildNumber.

  • Вы создадите следующий фильтр WMI на основе известных номеров сборок версий Windows:

    "Select BuildNumber from Win32_OperatingSystem WHERE BuildNumber >= 9200 "
    
    Номер сборки Версия Windows
    9200 Windows 8
    9600 Windows 8.1
    10240 Windows 10
    10586 Windows 10 версии 1511
    14393 Windows 10, версия 1607
    15063 Windows 10 версии 1703
    16299 Windows 10 версии 1709
    17134 Windows 10 версии 1803
    17763 Windows 10, версия 1809
    18362 Windows 10 версии 1903

В этом сценарии, хотя фильтр WMI приведет к применению параметра групповой политики к сборке 9200 и более поздних сборок, сборки Windows 10 исключены.

Причина

Эта проблема возникает, так как тип данных для BuildNumber — String, а не Целое число. Поэтому 10*** < 9600.

Решение

Чтобы устранить эту проблему, используйте фильтр, похожий на следующий пример.

Примечание.

Существует несколько способов принудительного сравнения строки, чтобы вернуть нужный результат. Вы можете использовать любой метод, который вы предпочитаете. Пример является полностью функциональным.

Select BuildNumber from Win32_OperatingSystem WHERE BuildNumber >= 10000 AND BuildNumber LIKE "%[123456789][0123456789][0123456789][0123456789][0123456789]%" OR BuildNumber >= 9200 AND BuildNumber LIKE "%[123456789][0123456789][0123456789][0123456789]%"

Сбор данных

Если вам нужна помощь от поддержки Майкрософт, рекомендуется собирать сведения, выполнив действия, описанные в статье "Сбор сведений" с помощью TSS для проблем с взаимодействием с пользователем.