Примечание
Для доступа к этой странице требуется авторизация. Вы можете попробовать войти или изменить каталоги.
Для доступа к этой странице требуется авторизация. Вы можете попробовать изменить каталоги.
В этой статье описывается решение проблемы, из-за которой состояние нового принтера находится в автономном режиме после удаления очереди печати и перезапуска компьютера под управлением Windows.
Исходный номер базы знаний: 2027593
Симптомы
Рассмотрим следующий сценарий:
- Вы удаляете очередь печати во время автономного состояния.
- Вы добавляете новую очередь печати, которая имеет то же имя, что и старая очередь печати.
- Перезагрузите компьютер.
В этом сценарии состояние новой очереди печати отображается как автономный.
Причина
Эта проблема возникает, если компьютер имеет следующее значение реестра, настроенное при настройке принтера в автономном состоянии:
Ключ: HKEY_CURRENT_CONFIG\System\CurrentControlSet\Control\Print\Printers\<print queue name>
значение: PrinterOnLine
Данные: 0
Однако это значение не удаляется файлом Localspl.dll при удалении очереди печати. Поэтому при добавлении очереди печати, которая имеет то же имя, что и старая очередь печати, новая очередь принтера наследует состояние "Автономный " для удаленной очереди печати.
Решение
Чтобы устранить эту проблему, щелкните правой кнопкой мыши новую очередь печати в средстве "Принтеры и факсы", а затем снимите параметр "Использовать принтер в автономном режиме ". При этом раздел реестра сбрасывается в правильное значение. Вместо этого можно удалить раздел реестра, упомянутый в разделе "Причина " после удаления очереди печати, но перед добавлением новой очереди печати с тем же именем.
Исправлена проблема
- Проверьте, устранена ли проблема. Если проблема устранена, вы закончите работу с этим разделом. Если проблема не устранена, обратитесь в службу поддержки.
- Ваши отзывы важны для нас! Чтобы отправить отзыв или сообщить о любых проблемах с этим решением, оставьте комментарий, отправив нам сообщение электронной почты .
Сбор данных
Если вам нужна помощь от поддержки Майкрософт, рекомендуется собирать сведения, выполнив действия, описанные в статье "Сбор сведений" с помощью TSS для проблем с взаимодействием с пользователем.