Сообщения об ошибках службы очереди печати принтера возникают после установки или обновления стороннего драйвера печати

Эта статья содержит решение для устранения ошибок службы очереди печати принтера, которые возникают после установки или обновления стороннего драйвера печати.

Применимо к: Windows 10 (все выпуски), Windows Server 2012 R2
Оригинальный номер базы знаний: 2793718

Симптомы

На клиентском компьютере под управлением Windows может возникнуть одна из следующих проблем:

  • Во время установки или обновлении стороннего драйвера печати могут возникнуть следующие сообщения об ошибках:

    • В ходе операции произошла ошибка 0x00000057
    • Драйвер принтера не установлен. Не удалось выполнить операцию (ошибка 0x00000057)
    • В ходе операции произошла ошибка 0x000005b3
    • Не удалось выполнить операцию (ошибка 0x00000bc4). Никакие принтеры не найдены.
    • Windows не удается подключиться к принтеру. Не удалось выполнить операцию (ошибка 0x00000002)
  • При попытке запустить или остановить службу очереди печати принтера может отобразиться следующее сообщение об ошибке:

    Диспетчер очереди печати обнаружил проблему и должен закрыться

  • При нажатии на кнопку Пуск и выборе команды Принтеры и факсы в Windows XP или выборе Устройства и принтеры в Windows Vista или более поздней версии, может появиться следующее сообщение об ошибке:

    Диспетчер очереди печати обнаружил ошибку и должен закрыться

  • При нажатии на кнопку Пуск и выборе команды Принтеры и факсы в Windows XP или выборе Устройства и принтеры в Windows Vista или более поздней версии принтеры не отображаются при попытке просмотра принтеров. Эта проблема может возникнуть даже при наличии установленных принтеров.

Причина

Эти проблемы могут возникнуть, если драйвер или служба стороннего принтера влияет на функциональные возможности существующего или недавно установленного принтера.

Решение

Чтобы очистить и сбросить очередь печати принтера, выполните следующие действия:

  1. В поле поиска на панели задач введите службы и выберите Службы из списка результатов.
  2. Перейдите на вкладку Стандарты, а затем дважды щелкните Очередь печати принтера в списке служб.
  3. Выберите Остановить, а затем нажмите ОК.
  4. В поле поиска на панели задач введите %WINDIR%\system32\spool\printers, выберите %WINDIR%\system32\spool\PRINTERS в списке результатов, затем удалите все файлы в папке.
  5. В поле поиска на панели задач задайте поиск служб, а затем выберите Службы из списка результатов поиска.
  6. Перейдите на вкладку Стандарты и дважды щелкните Очередь печати принтера в списке служб.
  7. Нажмите Пуск, выберите Автоматический в поле Тип запуска, затем нажмите OK.

Сбор данных

Если вам нужна помощь со стороны службы поддержки Майкрософт, рекомендуем собрать информацию, выполнив действия, описанные в статье Сбор информации с помощью TSS для проблем с взаимодействием с пользователем.