Can't access a new Customer Insights - Data environment
Note
On September 1, 2023, we merged and renamed Dynamics 365 Marketing and Dynamics 365 Customer Insights. Dynamics 365 Marketing is now called Dynamics 365 Customer Insights - Journeys. Dynamics 365 Customer Insights is now called Dynamics 365 Customer Insights - Data. For more information, see Dynamics 365 Customer Insights FAQs.
This article provides a resolution for an issue where you can't access a new Dynamics 365 Customer Insights - Data environment due to a disabled service principal.
Symptoms
When you sign in to Customer Insights - Data, you receive the following error message:
The service principal for resource <application ID> is disabled.
Cause
This issue occurs most likely because an administrator disabled user sign-in for the <application ID>
enterprise application in Azure.
Resolution
To solve this issue, follow these steps to enable user sign-in for the <application ID>
enterprise application.
Note
To enable user sign-in, you need admin permissions of Microsoft Entra ID.
- Sign in to Microsoft Entra ID in the Azure portal.
- Go to Enterprise applications.
- Open the Properties setting of the
<application ID>
enterprise application. - Set Enabled for users to sign-in? to Yes.
- Select Save.