Troubleshoot issues with emails
This article helps you troubleshoot and resolve issues related to emails in Dynamics 365 Sales.
Issue 1: Email editor shows incorrect title in contextual email popup window
After upgrading to Dynamics 365 2020 release wave 2, the email editor shows incorrect title in contextual email popup window.
Cause
For out of the box email forms, the onload
and onchange
events are triggered that helps in updating email title and other attributes in the contextual email popup. If you have a custom email form or an unmanaged layer form, the onload
and onchange
events won't be available. Therefore, the email title is displayed incorrectly.
Resolution
To resolve this issue, you must add the onload
and onchange
events to the custom email forms.
Add the custom email form to the newly created solution.
Add the following code in the form's XML:
<events> <event name="onload" application="true" active="true"> <InternalHandlers> <Handler functionName="Activities.Email.formOnload" libraryName="Activities/SystemLibraries/Email_main_system_library.js" handlerUniqueId="ecdfe4d8-d6d3-4d21-ab68-8ea75bb30a79" enabled="true" parameters="" passExecutionContext="true" /> <Handler functionName="Activities.Email.NotifyPanelSubjectChange" libraryName="Activities/SystemLibraries/Email_main_system_library.js" handlerUniqueId="{706607A8-4424-4C9A-847A-602FC8035B48}" enabled="true" parameters="" passExecutionContext="true" solutionaction="Added"/> </InternalHandlers> </event> <event name="onchange" application="true" active="true" attribute="subject" solutionaction="Added"> <Handlers> <Handler functionName="Activities.Email.NotifyPanelSubjectChange" libraryName="Activities/SystemLibraries/Email_main_system_library.js" handlerUniqueId="{706607A8-4424-4C9A-847A-602FC8035B48}" enabled="true" parameters="" passExecutionContext="true"/> </Handlers> </event> </events> <clientresources> <internalresources> <clientincludes> <internaljscriptfile src="$webresource:Activities/SystemLibraries/Email_main_system_library.js" /> </clientincludes> </internalresources> </clientresources>
Issue 2: Can't view untracked emails and meetings in auto capture
Auto capture doesn't show untracked emails and meetings for some or all users in an organization.
Cause
Starting from version 9.2.24031.00102, Dynamics 365 Sales follows the principle of least privilege access, which prevents users who have Conditional Access policies on their tenants from accessing untracked emails and meetings.
If a user can't see untracked emails and meetings, perform the following steps to verify whether the issue is caused by a Conditional Access policy.
Sign in to the Microsoft Entra admin center as at least a Conditional Access administrator.
Go to Identity > Monitoring & health > Sign-in logs.
Switch to the User sign-ins (non-interactive) tab and add the following filters:
- Application contains Dataverse
- Resource contains Microsoft Graph
- Status equals Failure
If some results are returned for the affected users, the issue is due to a Conditional Access policy.
Workaround
There's no resolution available for this issue as it's the expected behavior. As an alternative, users can use Microsoft Copilot for Sales in Outlook to record individual activities, or use server-side synchronization to track all emails and meetings automatically.