Vi är ledsna. Servern är inte tillgänglig eller har inte stöd för det här programmet. Ett fel uppstår när du ansluter till CRM-appen på en iPad eller iPhone
Den här artikeln innehåller en lösning på ett fel som uppstår när du ansluter en iPhone eller iPad till Dynamics CRM-appen.
Gäller för: Microsoft Dynamics CRM 2013, Microsoft Dynamics CRM 2015
Ursprungligt KB-nummer: 3069747
Symptom
När du försöker ansluta en iPhone eller iPad till Dynamics CRM-appen kan du få felet:
" Vi är ledsna. Servern är inte tillgänglig eller har inte stöd för det här programmet."
Orsak
SSL-certifikat som genereras av vissa externa certifikatutfärdare kan ha problem med att hela certifikatkedjan är betrodd när du konfigurerar CRM-appen på en iPhone eller iPad.
Mer information
Åtkomst till Microsoft Dynamics CRM webbplats via ett webbprogram fungerar korrekt. Men på iOS-enheter kan SSL-certifikatet som konfigurerats för AD FS och CRM ses som obetrott. Du ser liknande certifikatrelaterade fel när du använder iOS-appar som återger webbsidorna med UIWebViews och WKWebViews.
IOS-enhetsloggarna visas:
Autentisering: Autentiseringen avbröts.
Det har påträffats när SSL-certifikatet är ett jokerteckencertifikat för hela domänen, till exempel *.contoso.com
. Rotdomänen, till exempel https://contoso.com
fungerar korrekt. Underdomäner som https://crm.contoso.com
inte fungerar som förväntat. Detta kan bero på kompatibilitet med iOS-enheter och certifikat som visar alternativa namn på jokertecken för certifikatmottagare. Vi rekommenderar att du testar med certifikat vars rotnivå innehåller CRM-underdomänen, *.crm.domain.com
till exempel .