Email Router kan inte skicka e-post från Microsoft Dynamics på grund av behörigheter
Den här artikeln innehåller en lösning på ett problem där Email Router inte kan skicka e-post från Microsoft Dynamics på grund av behörigheter.
Gäller för: Microsoft Dynamics 365 Customer Engagement Online
Ursprungligt KB-nummer: 4494727
Symptom
När du använder Dynamics 365 Email Router för att skicka e-post från en Dynamics 365 instans kan e-postmeddelandet hamna i ett väntande sändningstillstånd och aldrig faktiskt skicka:
Undantagsloggarna för Dynamics Email Router kan visa följande fel:
Ett fel uppstod när utgående e-postmeddelanden skulle bearbetas:
https://disco.crm.dynamics.com/\<OrgName>
. System.ServiceModel.FaultException'1[Microsoft.Xrm.Sdk.OrganizationServiceFault]: Användaren har inte send-as-behörighet. (Felinformation är lika med undantagsinformation:ErrorCode: 0x8004480D
Meddelande: Användaren har inte behörighet att skicka som.
Orsak
Det här beteendet kan ha fungerat utan att behöva dessa behörigheter för tidigare versioner av Dynamics 365-programmet. På grund av ändringar som införts i säkerhetsmodellen i vissa iterationer av versionerna 8.2.2 och 9.x måste dessa behörigheter uttryckligen beviljas för att e-postrouter ska kunna skicka e-post till en annan användare.
Åtgärd
Användaren som skickar det här e-postmeddelandet måste tillåta att e-postmeddelanden skickas från andra Dynamics-användare i deras personliga alternativ:
Kontot som används av Email Router måste också ha behörigheten Skicka Email som en annan användare i Dynamics:
Mer information
Feedback
https://aka.ms/ContentUserFeedback.
Kommer snart: Under hela 2024 kommer vi att fasa ut GitHub-problem som feedbackmekanism för innehåll och ersätta det med ett nytt feedbacksystem. Mer information finns i:Skicka och visa feedback för