Konfigurera BFD över ExpressRoute

ExpressRoute stöder dubbelriktad vidarebefordransidentifiering (BFD) både över privat peering och Microsoft-peering. När du aktiverar BFD via ExpressRoute kan du påskynda identifieringen av länkfel mellan Microsoft Enterprise Edge-enheter (MSEE) och de routrar som konfigureras för din ExpressRoute-krets (CE/PE). Du kan konfigurera ExpressRoute via dina edge-routningsenheter eller dina Partner Edge-routningsenheter (om du har valt den hanterade Layer 3-anslutningstjänsten). Det här dokumentet beskriver behovet av BFD och hur du aktiverar BFD via ExpressRoute.

Behov av BFD

Följande diagram visar fördelen med att aktivera BFD över ExpressRoute-kretsen: 1

Du kan aktivera ExpressRoute-kretsen antingen via Layer 2-anslutningar eller hanterade Layer 3-anslutningar. I båda fallen, om det finns fler än en Layer-2-enhet i ExpressRoute-anslutningssökvägen, ligger ansvaret för att identifiera eventuella länkfel i sökvägen på den överdrivna BGP-sessionen.

På MSEE-enheterna konfigureras BGP keep-alive och hold-time vanligtvis som 60 respektive 180 sekunder. Av den anledningen kan det ta upp till tre minuter att identifiera eventuella länkfel och växla trafik till en annan anslutning när ett länkfel inträffar.

Du kan styra BGP-timers genom att konfigurera en lägre BGP keep-alive och hold-time på din edge-peeringenhet. Om BGP-timers inte är samma mellan de två peeringenheterna upprättas BGP-sessionen med det lägre tidsvärdet. BGP keep-alive kan anges så lågt som tre sekunder och väntetiden så låg som 10 sekunder. Att ange en mycket aggressiv BGP-timer rekommenderas dock inte eftersom protokollet är processintensivt.

I det här scenariot kan BFD hjälpa till. BFD ger felidentifiering med låg overheadlänk i ett tidsintervall på undersekunder.

Anteckning

BFD ger snabbare redundans när ett länkfel identifieras, men den övergripande anslutningskonvergensen tar upp till en minut för redundans mellan virtuella ExpressRoute-nätverksgatewayer och MSEEs.

Aktivera BFD

BFD konfigureras som standard under alla nyligen skapade privata ExpressRoute- och Microsoft-peeringgränssnitt på MSEEs. För att aktivera BFD behöver du därför bara konfigurera BFD på både dina primära och sekundära enheter. Att konfigurera BFD är en process i två steg. Du konfigurerar BFD i gränssnittet och länkar den sedan till BGP-sessionen.

Ett exempel på CE/PE-konfiguration (med Cisco IOS XE) visas nedan.

interface TenGigabitEthernet2/0/0.150
   description private peering to Azure
   encapsulation dot1Q 15 second-dot1q 150
   ip vrf forwarding 15
   ip address 192.168.15.17 255.255.255.252
   bfd interval 300 min_rx 300 multiplier 3


router bgp 65020
   address-family ipv4 vrf 15
      network 10.1.15.0 mask 255.255.255.128
      neighbor 192.168.15.18 remote-as 12076
      neighbor 192.168.15.18 fall-over bfd
      neighbor 192.168.15.18 activate
      neighbor 192.168.15.18 soft-reconfiguration inbound
   exit-address-family

Anteckning

Om du vill aktivera BFD under en redan befintlig privat peering eller Microsoft-peering måste du återställa peering. Detta måste göras på kretsar som konfigurerats med privat peering före augusti 2018 och Microsoft-peering före januari 2020. Se Återställa ExpressRoute-peering

BFD Timer-förhandling

Mellan BFD-peer-datorer avgör den långsammare av de två peer-datorerna överföringshastigheten. MSEEs BFD-överförings-/mottagningsintervall är inställda på 300 millisekunder. I vissa scenarier kan intervallet anges till ett högre värde på 750 millisekunder. Genom att konfigurera ett högre värde kan du tvinga dessa intervall att vara längre, men det går inte att göra dem kortare.

Anteckning

Om du har konfigurerat Geo-redundanta ExpressRoute-kretsar eller använder IPSec VPN-anslutning från plats till plats som säkerhetskopia. Om du aktiverar BFD kan du snabbare redundansväxling efter ett ExpressRoute-anslutningsfel.

Nästa steg

Mer information eller hjälp finns på följande länkar: