Felsöka fel med Azure Blueprints

Viktigt

Den 11 juli 2026 blir skisser (förhandsversion) inaktuella. Migrera dina befintliga skissdefinitioner och tilldelningar till mallspecifikationer och distributionsstackar. Skissartefakter ska konverteras till ARM JSON-mallar eller Bicep-filer som används för att definiera distributionsstackar. Information om hur du skapar en artefakt som en ARM-resurs finns i:

Du kan stöta på fel när du skapar, tilldelar eller tar bort skisser. Den här artikeln beskriver olika fel som kan uppstå och hur du löser dem.

Hitta felinformation

Många fel beror på att en skiss har tilldelats till ett omfång. När en tilldelning misslyckas tillhandahåller skissen information om den misslyckade distributionen. Den här informationen anger problemet så att det kan åtgärdas och nästa distribution lyckas.

  1. Välj Alla tjänster i den vänstra rutan. Sök efter och välj Skisser.

  2. Välj Tilldelade skisser på sidan till vänster och använd sökrutan för att filtrera skisstilldelningarna och hitta den misslyckade tilldelningen. Du kan också sortera tabellen med tilldelningar efter kolumnen Etableringstillstånd för att se alla misslyckade tilldelningar grupperade tillsammans.

  3. Välj skissen med statusen Misslyckades eller högerklicka och välj Visa tilldelningsinformation.

  4. En röd banderoll som varnar för att tilldelningen har misslyckats finns överst på skisstilldelningssidan. Välj var som helst på banderollen, så visas mer information.

Det är vanligt att felet orsakas av en artefakt och inte skissen som helhet. Om en artefakt skapar ett Key Vault och Azure Policy förhindrar att Key Vault skapas misslyckas hela tilldelningen.

Allmänna fel

Scenario: Principöverträdelse

Problem

Malldistributionen misslyckades på grund av en principöverträdelse.

Orsak

En princip kan vara i konflikt med distributionen av följande skäl:

  • Resursen som skapas begränsas av principen (vanligtvis SKU eller platsbegränsningar)
  • Distributionen anger fält som konfigureras av principen (vanliga med taggar)

Lösning

Ändra skissen så att den inte står i konflikt med principerna i felinformationen. Om den här ändringen inte är möjlig är ett alternativt alternativ att ändra omfånget för principtilldelningen så att skissen inte längre står i konflikt med principen.

Scenario: Skissparametern är en funktion

Problem

Skissparametrar som är funktioner bearbetas innan de skickas till artefakter.

Orsak

Om du skickar en skissparameter som använder en funktion, till exempel [resourceGroup().tags.myTag], till en artefakt resulterar det bearbetade resultatet av funktionen som anges på artefakten i stället för den dynamiska funktionen.

Lösning

Om du vill skicka igenom en funktion som en parameter kan du undvika hela strängen så [ att skissparametern ser ut som [[resourceGroup().tags.myTag]. Escape-tecknet gör att skisser behandlar värdet som en sträng när skissen bearbetas. Blueprints-tjänsten placerar sedan funktionen på artefakten så att den kan vara dynamisk som förväntat. Mer information finns i Syntax och uttryck i Azure Resource Manager-mallar.

Ta bort fel

Scenario: Tidsgräns för borttagning av tilldelning

Problem

Borttagningen av en skisstilldelning slutförs inte.

Orsak

En skisstilldelning kan fastna i ett icke-terminaltillstånd när den tas bort. Det här tillståndet orsakas när resurser som skapats av skisstilldelningen fortfarande väntar på borttagning eller inte returnerar en statuskod till Azure Blueprints.

Lösning

Skisstilldelningar i ett icke-terminaltillstånd markeras automatiskt som Misslyckade efter en tidsgräns på sex timmar . När tidsgränsen har justerat tillståndet för skisstilldelningen kan borttagningen göras på nytt.

Nästa steg

Om du inte ser problemet eller inte kan lösa problemet kan du besöka någon av följande kanaler för mer support:

  • Få svar från Azure-experter via Azure-forum.
  • Anslut med @AzureSupport – det officiella Microsoft Azure-kontot för att förbättra kundupplevelsen genom att ansluta Azure-communityn till rätt resurser: svar, support och experter.
  • Om du behöver mer hjälp kan du skicka in en Azure Support incident. Gå till Azure Support-webbplatsen och välj Hämta support.