Dela via


Outlook kan inte ansluta via en brandvägg eller en proxyserver som utför NAT (Network Address Translation) mellan offentliga och privata nätverk

Ursprungligt KB-nummer: 291615

Symptom

Outlook-klienter kan inte ansluta via en brandvägg eller proxyserver som utför NAT mellan offentliga och privata nätverk.

Orsak

När IP-paketen som innehåller RPC-information (Remote Procedure Call) redigeras under översättningen förlorar IP-paketen RPC-anslutningsinformationen. Detta gör att klienten inte ansluter till servern. Dessutom kan Outlook ha problem med att lösa namnet på den Microsoft Exchange Server datorn bakom brandväggen eller proxyservern.

Lösning

En lösning för brandväggar eller proxyservrar som inte är baserade på Microsoft Windows NT är att utföra en en-till-en-översättning mellan de två nätverken. Detta kallas även för att öppna ett rör eller en tunnel mellan de offentliga och privata nätverken. Detta tar alla begäranden om en specifik adress i det offentliga nätverket och skickar dem direkt till det privata nätverket. Mer information om hur du konfigurerar en en-till-en-översättning finns i tillverkarens dokumentation.

En en-till-en-översättning eller pipe fungerar inte för Windows NT-baserade brandväggar och proxyservrar eftersom Outlook-klienten försöker binda till slutpunktsmappningsporten (EPM), port 135, i brandväggen. Den här servern returnerar inte rätt Exchange Server anslutningsinformation till Outlook-klienten.

En annan möjlig lösning är att använda Outlook Web App. Detta kräver endast att HTTP-trafik tillåts via brandväggen eller proxyservern.

Mer information

Mer information finns i följande begäranden om kommentarer (RFC):

  • RFC 1631 – IP-nätverksadressöversättaren (NAT)
  • RFC 1918 – Adressallokering för privat Internet

Dessa RFC:er finns här.