Dela via


Innehållsindextillståndet fastnar i crawlning i en Exchange Server 2010-databas

Ursprungligt KB-nummer: 2820817

Symptom

På en Microsoft Exchange Server 2010-databas visas innehållsindextillståndet som "crawlning" och det verkar aldrig nå tillståndet "felfri". Även om prestandaräknaren Antal dokument har indexerats visar en progressiv ökning av antalet indexerade dokument, minskar inte värdet i räknaren Antal postlådor kvar till crawlning som förväntat.

I det här fallet loggas följande händelser i programloggen:

Time:
ID: 102
Level: Error
Source: MSExchange Search Indexer
Machine: Mailboxserver.contoso.com
Message: Exchange Search Indexer has failed to crawl the mailbox (8832ee80-47b8-4b0e-a98f-c4a239794707) in database (Database1) due to error: (Microsoft.Exchange.Search.MailboxCrawlFailedException: Failed to logon to mailbox). This mailbox will be retried later.
Time:
ID: 5617
Level: Error
Source: CI Troubleshooter
Machine: Mailboxserver.contoso.com
Message: CI troubleshooter exchange search service restart attempt 81.

Orsak

Det här problemet uppstår när System Center Operations Manager kör det Toubleshoot-CI.ps1 skriptet. Detta gör att Exchange-tjänsten Search startas om innan indexeringsprocessen slutförs.

Åtgärd

Lös problemet genom att förhindra att System Center Operations Manager-servern kör Troubleshoot-CI.ps1 skriptet på följande sätt:

  1. Öppna System Center Operations Manager.
  2. Klicka på Övervakning av hanteringspaketobjekt>.
  3. I rutan Sök efter skriver du felsökning och klickar sedan på Sök nu.
  4. Leta upp det objekt som motsvarar Troubleshoot-CI.ps1 skript, högerklicka på det och klicka sedan på Egenskaper.
  5. Klicka på Åsidosätt på fliken Åsidosätt.
  6. Markera kryssrutan Aktiverad , ställ in alternativet Åsidosätt värdeFalskt och klicka sedan på OK.

Mer information

Vanligtvis kör System Center Operations Manager Troubleshoot-CI.ps1 skript varannan timme. Men om Troubleshoot-CI.ps1-skriptet identifierar något av följande symptom utlöser det en omstart av Exchange-söktjänsten:

  • Deadlock: Exchange Search deadlocks while waiting on threads from MSSearch.
  • Skadad: Ett eller flera sökindex är skadade.
  • Stall: Liknar ett dödläge eftersom indexen inte uppdateras.
  • Kvarvarande uppgifter: Sökkatalogen är igensatt, så schemalagda indexsökningar körs inte som förväntat.

Här är ett exempel på en händelse som loggas när Troubleshoot-CI.ps1-skriptet körs:

Time:
ID: 5611
Level: Error
Source: CI Troubleshooter
Machine: Mailboxserver.contoso.com
Message: Indexing backlog reached a critical limit of 48 hours or the number of items in the retry queue is greater than 10000 for one or more databases: Database1 (0, 12572, 0)Database1 (0, 31859, 0)

Om databaserna har stora postlådor eller postlådor med högt antal objekt tar det vanligtvis längre tid än två timmar att slutföra indexeringsprocessen. Och när Exchange-söktjänsten startas om placeras postlådorna tillbaka i listan för omindexering. I det här fallet kanske crawlningsprocessen aldrig får chansen att slutföras.