Anteckning
Åtkomst till den här sidan kräver auktorisering. Du kan prova att logga in eller ändra kataloger.
Åtkomst till den här sidan kräver auktorisering. Du kan prova att ändra kataloger.
Symptome
På en Windows-enhet som har säkerhetsprogramvara installerad kan något av följande problem uppstå när du försöker logga in på Microsoft 365-skrivbordsprogram:
Inloggningsprompterna är tillfälliga.
Inloggningsfönstret visar en tom autentiseringsskärm.
Inloggningsfönstret har fastnat vid autentisering.
Outlook Desktop-klienten visar meddelandet "Försöker ansluta...".
Teams skrivbordsklient visar meddelandet "Vi kunde inte ansluta. Logga in så försöker vi igen."
Du öppnar Händelselogg och väljer Windows-loggar>Program. När du undersöker informationen om AppModel-State-posterna i kolumnen Källa i tabellen visas något av följande händelsemeddelanden som slutar med en varnings- eller felkod
-2147xxxxxx
:-
Det gick inte att läsa in programinställningarna för paketet
-
Reparation av tillståndsplatser för åtgärdsinställningarInitialisera mot paket Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy med fel
-
Reparation för funktion LocalSettings mot paketet Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy med fel.
-
Utlöst reparation eftersom operationen LocalSettings mot paket Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy resulterade i fel
-
Utlöst reparation av tillstånd eftersom åtgärden Initiera inställningar för paketet Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy stötte på ett fel.
-
Orsak
Problemet kan orsakas av befintliga eller föråldrade WFP-drivrutiner (Windows Filtering Platform) i säkerhetsprogramvaran. I den här situationen förhindrar säkerhetsprogramvaran nätverkskommunikation från att upprättas eller upprätthålla det tidigare kommunikationstillståndet. Dessutom kan säkerhetsprogramvaran blockera WAM-plugin-program (Web Account Manager) eller ta bort plugin-programmen som en bieffekt av dess aktivitet på enheten.
Om Händelsevisaren visar något av händelsemeddelandena som anges i avsnittet "Symptom", tyder meddelandena på att WAM-plugin-programmen är trasiga eller har manipulerats.
Anmärkning
- WAM-plugin-programmen används av Microsoft 365-appar för att upprätta och förnya inloggningssessioner. Plugin-programmen installeras i kontexten för användarprofilen. Det innebär att även om en användare kan uppleva problem kanske inte en annan användare på samma enhet. Därför bör alla åtgärder och diagnoser utföras inom ramen för den berörda användaren, inte på enhetsnivå eller administratörsnivå.
- Om plugin-programmen har skadats, manipulerats eller tagits bort från användarprofilen på grund av säkerhetsprogramgenomsökning kan du försöka installera plugin-programmen upprepade gånger med hjälp av ett PowerShell-bakgrundsskript eller ett inloggningsskript för grupprincip. Den här åtgärden kan tillfälligt åtgärda problemet till nästa antivirusgenomsökning.
Lösning / Beslut
Viktigt!
Om problemet orsakas av ett trasigt eller manipulerat WAM-plugin-program går du vidare till steg 3 i följande procedur för att installera om WAM-plugin-programmen. Om problemet uppstår igen kan du samarbeta med din säkerhetsprogramvara och WFP-drivrutinsleverantören för att konfigurera lämpliga undantag som anges i steg 5.
Följ dessa steg på enheten för att åtgärda problemen:
Logga in med ett administratörskonto och avinstallera sedan säkerhetsprogramvaran tillfälligt och eventuella fristående eller föråldrade WFP-drivrutiner från enheten.
Logga in med den berörda användarens autentiseringsuppgifter och kontrollera sedan om WAM-plugin-programmen är installerade och kan köras korrekt i användarens profil.
Kör följande PowerShell-cmdletar:
Get-AppxPackage Microsoft.AAD.BrokerPlugin Get-AppxPackage Microsoft.Windows.CloudExperienceHost
Om någon av cmdletarna inte returnerar något går du till steg 3. Annars kör du följande kommandon i en kommandotolk:
explorer.exe shell:appsFolder\Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy!App explorer.exe shell:appsFolder\Microsoft.Windows.CloudExperienceHost_cw5n1h2txyewy!App
Om fönstret Arbets- eller skolkonto eller Microsoft-konto inte öppnas går du till steg 3. Annars går du till steg 4.
Om steg 2 inte lyckas installerar du om WAM-plugin-programmen med hjälp av följande PowerShell-cmdletar:
Add-AppxPackage -Register "$env:windir\SystemApps\Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy\Appxmanifest.xml" -DisableDevelopmentMode -ForceApplicationShutdown Add-AppxPackage -Register "$env:windir\SystemApps\Microsoft.Windows.CloudExperienceHost_cw5n1h2txyewy\Appxmanifest.xml" -DisableDevelopmentMode -ForceApplicationShutdown
Övervaka i 48 timmar. Kontakta Microsoft Support om problemet uppstår igen. Gå annars till steg 5.
Anmärkning
För felsökning rekommenderar vi att du samlar in data från processövervakaren när du återskapar problemet. Den här informationen kan hjälpa dig att avgöra om:
- Moduler från tredje part läses in tillsammans med WAM-plugin-programmen.
- Moduler från tredje part håller filen eller registerlåset och förhindrar inloggningsprocessen.
- Föråldrade WFP- eller säkerhetsprogramdrivrutiner installeras i systemet.
Logga in med ett administratörskonto och installera om säkerhetsprogramvaran och fristående WFP-drivrutiner som avinstallerades i steg 1. Arbeta sedan med din säkerhetsprogramvara och WFP-drivrutinsleverantör för att konfigurera följande paket, mapp och processundantag i säkerhetsprogramvaran och WFP-drivrutinerna.
Paketfamiljenamn som ska uteslutas
Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy
Microsoft.Windows.CloudExperienceHost_cw5n1h2txyewy
Mappplatser att exkludera
%windir%\SystemApps\Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy
%localappdata%\Packages\Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy
%windir%\SystemApps\Microsoft.Windows.CloudExperienceHost_cw5n1h2txyewy
%localappdata%\Packages\Microsoft.Windows.CloudExperienceHost_cw5n1h2txyewy
%localappdata%\Microsoft\TokenBroker
%localappdata%\Microsoft\OneAuth
%localappdata%\Microsoft\IdentityCache
Processer som ska undantas
%windir%\SystemApps\Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy\Microsoft.AAD.BrokerPlugin.exe
-
%windir%\System32\backgroundTaskHost.exe
för följande paketnamn:Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy
Microsoft.Windows.CloudExperienceHost_cw5n1h2txyewy
-
%windir%\System32\svchost.exe
laddar NT-tjänstenTokenBroker
som TokenBroker.dll