Dela via


Office 2013 kan inte checka in filer när LAN inte har Internetåtkomst eller via vissa VPN

Den här artikeln skrevs av Warren Rath, supporteskaleringstekniker.

I de fall där VPN orsakar det här problemet har vi hittat ett problem i Windows-kod (113100710844135), korrigeringen är ute VPN-klienten från tredje part stoppar Internetanslutningen i Windows 7 SP1 eller Windows Server 2008 R2 SP1. Vi har kontrollerat att Palo Alto Networks Global Protect Client och Juniper VPN fungerar med den här korrigeringen.

Kunder använder VPN-lösningar från tredje part i Windows 7. Om kunder migrerar till Office 2013 från en äldre version av Office kan de uppleva funktionsförlust i Office när de är anslutna via VPN. Office 2013 var beroende av NLA (Network Location Awareness) och vissa VPN-lösningar fungerar inte korrekt med NLA. Mer specifikt om VPN-programvaran inte definierar en standardgateway. I det här fallet rapporterar NLA alltid att klienten inte är ansluten till Internet. Detta påverkar Office2013 eftersom det är beroende av Internetanslutning för vissa funktioner. Det finns till exempel ingen hjälpfil på datorn och all hjälp finns på Internet. Om en kund trycker på F1 i ett Office 2013-program får de alltid ett felmeddelande om att de inte är anslutna till Internet när de är anslutna via VPN.

Symptom

Användare utan fullständig Internetåtkomst kanske inte kan checka in filer från Office 2013-klienten, även om det finns en bra anslutning mellan Office-klienten och SharePoint-servern.

Orsak

Det skedde en designändring mellan Office 2010 och 2013, där 2013 nu kräver en Internetanslutning för vissa aktiviteter. Vissa kunder har redan klagat på det här problemet och produktgruppen har informerats om designbegränsningarna. (men det finns för närvarande ingen snabbkorrigering på gång, en snabbkorrigering kanske inte är möjlig, vilket ser ut att vara en betydande ändring)

Roten till problemet verkar vara att Office 2013 är beroende av NLA (Network Location Awareness). NLA använder avsökningar för att avgöra om nätverksanslutningen har "Internetåtkomst". Sättet som det är är detta på två sätt.

  1. Den utför en DNS-avsökning för dns.msftncsi.com. Den förväntar sig ett specifikt svar. Svaret måste vara 131.107.255.255. Om så är fallet är det rätt DNS-avsökning.
  2. Den försöker ansluta till https://www.msftncsi.com och försöker hämta filen ncsi.txt. I filen måste texten vara "Microsoft NCSI".

Om båda ovanstående villkor uppfylls markeras anslutningen som internetanslutning, om inte anslutningen markeras som att den inte har någon Internetanslutning och vissa Office-funktioner fungerar inte.

Lösning

Det går att konfigurera en lokal NCIS-server (statusindikator för nätverksanslutning) på ditt LAN som svarar på Office-klienternas begäran och tillåter att Office-funktionen fungerar.

Se inlägget nedan för relaterad information och anvisningar: