Dela via


Felet "Begär dina CRM-administratörsbehörigheter för att få åtkomst till Salesforce med API:er"

Den här artikeln hjälper dig att felsöka och lösa problem när ett felmeddelande visas när du har anslutit och loggat in på Salesforce CRM i Microsoft Copilot for Sales.

Obs!

Microsoft Sales Copilot byter namn till Microsoft Copilot for Sales i januari 2024. Skärmbilderna i den här artikeln kommer snart att uppdateras med det nya namnet.

Vem påverkas?

Typ av krav Beskrivning
Klientapp Copilot for Sales Outlook-tillägg
Plattform Webb- och skrivbordsklienter
OS Windows och Mac
Distribution Användarhanterad och administratörshanterad
CRM Salesforce
Användare Användare som försöker använda Copilot for Sales med Salesforce CRM

Symptom

När du har loggat in på Salesforce CRM via tillägget Copilot for Sales för Outlook visas följande felmeddelande:

Begär dina CRM-administratörsbehörigheter för att få åtkomst till Salesforce med hjälp av API:er

Skärmbild som visar API-behörighetsfelet.

Orsak

Problemet uppstår när du inte har API-behörigheter i Salesforce. Du kan kontrollera om det här är rotorsaken till problemet om du ser följande fel i loggarna:

Exception thrown in VivaSalesContacts/GetContactsByEmailAddress - 
Microsoft.SalesProductivity.Common.Base.SPServiceException: Salesforce failed to complete task: Message: entity is deleted clientRequestId: {CLIENT REQUEST ID HERE}-self ---> 
System.Exception: { 
    "error": { 
        "code": 502, 
        "source": "{APIM SOURCE}", 
        "message": "BadGateway", 
        "innerError": { 
            "status": 502, 
            "message": "Salesforce failed to complete task: Message: **API is disabled for this User**\r\nclientRequestId: {CLIENT REQUEST ID HERE}", 
            "error": null, 
            "source": "Salesforce.Common", 
            "errors": [] 
        } 
    } 
} 

Åtgärd

En administratör kan ge API-aktiverad behörighet till användaren eller den berörda användarens profil genom att följa dessa steg:

  1. Logga in på Salesforce som administratör.

  2. I sökrutan anger du Användare.

  3. I det vänstra navigeringsfönstret väljer du Profiler och sedan den berörda användarens profil.

  4. I avsnittet Administrativa behörigheter väljer du API-aktiverat.

  5. Välj Spara.

    Skärmbild som visar alternativet API-aktiverat på sidan Profiler.

Mer information

Om problemet fortfarande är olöst går du till Copilot for Sales – Microsoft Community Hub för att kontakta våra experter.

Ansvarsfriskrivning för information från tredje part

De produkter från andra tillverkare som diskuteras i denna artikel tillverkas oberoende av Microsoft. Produkternas funktion eller tillförlitlighet kan därför inte garanteras.