Felet "ServiceUnavailable (409) – begärd resurs är inte tillgänglig på platsen"

I den här artikeln beskrivs hur du löser felet "ServiceUnavailable (409) ("Den begärda resursen är inte tillgänglig på platsen" "<regionnamn>" just nu")" som inträffar när du försöker distribuera en resurs i Microsoft Azure Container Instances.

Symptom

Du får ett felmeddelande som liknar följande text:

Den begärda resursen är inte tillgänglig på platsen "<region>" just nu. Försök igen med en annan resursbegäran eller på en annan plats. Begärd resurs: "2" CPU "4" GB minne "Linux" OPERATIVSYSTEM virtuellt nätverk. ServiceUnavailable (409).

Orsak

Det här problemet kan inträffa om en funktion inte är tillgänglig i vissa regioner eller om det saknas kapacitet. Det här problemet är vanligtvis tillfälligt.

När begäranden om distribution av containergrupper är större än fyra (4) processorer eller 16 GB minne markeras distributionen som stor containergrupp. Stor containergruppens regionskapacitet aktiveras vid behov och om det inte finns någon tillgänglig infrastruktur för distribution uppstår ett fel.

Lösning

  • Information om huruvida du kan distribuera till en tillgänglig region finns i Resurstillgänglighet och kvotgränser för Azure Container Instances.
  • Om du vill ta reda på vilka funktioner som är tillgängliga i din region använder du REST-API:et Plats – lista. Du kan också verifiera tillgängliga funktioner per region genom att välja knappen "Prova" i den artikeln.
  • Om du distribuerar i en tillgänglig region och det inte finns någon funktionsbegränsning kan du försöka distribuera igen.
  • Om du distribuerar en stor containergrupp öppnar du ett supportärende för att verifiera regionkapaciteten.