Felsök felkoden för WINDOWS_CSE_ERROR_CHECK_API_SERVER_CONNECTIVITY (5)

I den här artikeln beskrivs hur du identifierar och löser felet "WINDOWS_CSE_ERROR_CHECK_API_SERVER_CONNECTIVITY" (5) som inträffar när du försöker lägga till en Windows-nodpool i ett AKS-kluster (Azure Kubernetes Service).

Förutsättningar

Ett av följande verktyg krävs:

Symptome

När du försöker lägga till en Windows-nodpool i ett AKS-kluster får du följande felmeddelande:

Code="VMExtensionProvisioningError"
Message="CSE Error: WINDOWS_CSE_ERROR_CHECK_API_SERVER_CONNECTIVITY." Avslutningskod: 5. Information: Det går inte att upprätta en anslutning från agenter till Kubernetes API-servern.

Orsak

Klusternoderna kan inte koppla upp sig mot kluster-API-servern.

Felsökningssteg

  1. Kontrollera att noderna kan matcha klustrets fullständigt kvalificerade domännamn (FQDN):

    Kör följande kommando på befintliga Windows-noder:

    Test-NetConnection -ComputerName <cluster-fqdn> -Port 443
    

    Eller kör följande kommando på befintliga Linux-noder:

    nc -vz <cluster-fqdn> 443
    
  2. Om kommandoutdata visas False eller Timeoutkontrollerar du nätverkskonfigurationen. Kontrollera till exempel om du anger "Neka"-regler för API-servern i nätverkssäkerhetsgrupper (NSG:er) för det virtuella nätverket.

  3. Om du använder utgående filtrering via en brandvägg kontrollerar du att trafik tillåts till klustrets fullständiga domännamn.

  4. Om du har auktoriserade IP-adresser som är aktiverade i klustret kan brandväggens utgående IP-adress blockeras. I det här scenariot måste du lägga till brandväggens utgående IP-adress i listan över auktoriserade IP-intervall för klustret. Mer information finns i Säker åtkomst till API-servern med hjälp av auktoriserade IP-adressintervall i AKS.

Referenser

Allmän felsökning av problem med att skapa AKS-kluster

Ansvarsfriskrivning för information från tredje part

Produkter från tredje part som beskrivs i den här artikeln tillverkas av företag som är oberoende av Microsoft. Microsoft ger ingen garanti, uttrycklig eller underförstådd, angående prestandan eller tillförlitligheten hos dessa produkter.

Kontakta oss för att få hjälp

Om du har frågor kan du ställa support för Azure-communityn. Du kan också lämna produktfeedback till Azure feedback-community.