Dela via


Fel AADSTS50011 med SAML-autentisering – svars-URL:en som anges i begäran matchar inte

Den här artikeln innehåller en lösning på det AADSTS50011 fel som inträffar under federerad autentisering med Microsoft Entra ID.

Symptom

Du får ett felmeddelande AADSTS50011 när du försöker logga in på ett program som har konfigurerats för att använda Microsoft Entra ID för identitetshantering med SAML-baserad enkel inloggning.

Fel AADSTS50011 – Svars-URL:en matchar inte svars-URL:erna som konfigurerats för programmets <GUID>. Kontrollera att svars-URL:en som skickas i begäran matchar en som lagts till i ditt program i Azure Portal. Gå till https://aka.ms/urlMismatchError för att lära dig mer om hur du åtgärdar detta." när du försöker logga in på en SAML-baserad app med enkel Sign-On (SSO) som har integrerats med Microsoft Entra ID.

Orsak

Värdet AssertionConsumerServiceURL i SAML-begäran matchar inte värdet för svars-URL:en eller mönstret som konfigurerats i Microsoft Entra ID. Värdet AssertionConsumerServiceURL i SAML-begäran är den URL som visas i felet.

Lösning

Du löser problemet genom att följa dessa steg:

  1. Kontrollera att AssertionConsumerServiceURL värdet i SAML-begäran matchar värdet för svars-URL:en som konfigurerats i Microsoft Entra ID.
  2. Verifiera eller uppdatera värdet i textrutan Svars-URL så att det AssertionConsumerServiceURL matchar värdet i SAML-begäran.

I följande artikel finns till exempel detaljerade anvisningar om hur du konfigurerar värdena i Microsoft Entra ID:

Obs!

Svars-URL:en kallas även omdirigerings-URI. Dessa värden beror på vilket program som används. Du bör hämta värdena från programleverantören.

När du har uppdaterat värdet för svars-URL i Microsoft Entra ID och det matchar värdet som skickas av programmet i SAML-begäran bör du kunna logga in på programmet.

Mer information

En fullständig lista över felkoder för Active Directory-autentisering och auktorisering finns i Microsoft Entra felkoder för autentisering och auktorisering.

Kontakta oss för att få hjälp

Om du har frågor eller behöver hjälp skapar du en supportförfrågan eller frågar Azure community support. Du kan också skicka produktfeedback till Azure-feedbackcommunityn.