Dela via


Om du tar bort serviceavtal eller SLA-objekt visas ett fel i enhetligt gränssnitt under en lösningsuppgradering eller manuell borttagning

Den här artikeln innehåller en lösning på problemet där borttagning av serviceavtal (SLA) eller SLA-objekt visar ett felmeddelande i Enhetligt gränssnitt under en lösningsuppgradering eller manuell borttagning.

Symptom

När du försöker ta bort serviceavtal eller SLA-objekt under en lösningsuppgradering eller manuell borttagning uppstår något av följande felmeddelanden:

Objektet som du försökte ta bort är associerat med ett annat objekt och kan inte tas bort.

SLAItem-borttagningsåtgärden påträffade vissa fel. Processen är en del av en hanterad lösning och kan inte tas bort individuellt. Avinstallera den överordnade lösningen för att ta bort processen. Mer information finns i loggen.

Orsak

Det första felmeddelandet uppstår eftersom relationen mellan SLA-objektet och SLA KPI-instanserna är inställd på "Begränsa till ta bort" i serviceavtalet för enhetligt gränssnitt. Det andra felmeddelandet uppstår eftersom processer som ingår i en hanterad lösning inte kan tas bort. Om du försöker ta bort ett serviceavtal som ingår i en hanterad lösning manuellt och har konfigurerat flöden visas felmeddelandet.

Lösning 1

I stället för att ta bort serviceavtalet inaktiverar du serviceavtalet i din organisation. Om den ingår i en hanterad lösning utför du följande steg:

  1. Inaktivera serviceavtalet i källinstansen och lägg till det i lösningen.
  2. Inaktivera samma serviceavtal i målinstansen och tillämpa sedan lösningsuppgradering.

Lösning 2

Du kan först ta bort alla SLA-relaterade entitetsposter och SLA KPI-instanser manuellt och sedan ta bort serviceavtalet. Här är stegen:

  1. I din organisation går du till Avancerad sökning, söker efter SLA KPI-instanser och väljer sedan SLAItem.
  2. Välj Resultat. SLA KPI-instanserna visas.
  3. Välj de SLA KPI-instanser som krävs och välj sedan Ta bort SLAKPIInstances. Detta kommer också att nullifiera SLA KPI-instanserna på de relaterade posterna.

Även efter borttagning av referensposterna, om felmeddelandet "SLAItem delete operation påträffade några fel. Processen är en del av en hanterad lösning och kan inte tas bort individuellt. Avinstallera den överordnade lösningen för att ta bort processen. Se loggen för mer information" visar och tillämpa sedan lösningsuppgradering med serviceavtalet borttaget från uppgraderingslösningen.

Lösning 3

Om ovanstående lösning inte fungerar kontaktar du Microsoft Support för att begära borttagning av SLA- eller SLA-objekten.