Dela via


Det går inte att hitta några appar för ditt rollfelmeddelande i Microsoft Dynamics 365 för telefoner och surfplattor

Den här artikeln innehåller en lösning på ett fel som uppstår när du använder Microsoft Dynamics 365 för telefoner och surfplattor.

Gäller för: Microsoft Dynamics 365
Ursprungligt KB-nummer: 4486472

Symptom

När du använder Dynamics 365 för telefoner och surfplattor får du följande meddelande:

"Vi kan inte hitta några appar för din roll. Om du vill söka efter nyligen tillagda appar väljer du Uppdatera.
Om du inte hittar din app ändrar du sökvillkoren och försöker igen."

Orsak

Orsak 1: Du har inga Dynamics 365 säkerhetsroller som ger åtkomst till appar med enhetligt gränssnitt.

Orsak 2: Du har ingen Dynamics 365 säkerhetsroll med behörigheten Modelldrivna appar.

Åtgärd

Lösning 1: Kontrollera att användaren har åtkomst till minst en enhetlig gränssnittsapp.

  1. Få åtkomst till Dynamics 365 webbappen som en användare med säkerhetsrollen Systemadministratör.

  2. Gå till Inställningar och välj sedan Mina appar.

    Obs!

    Om du inte ser Mina appar kan du lägga till /apps i slutet av url:en:https://<your_organization_URL>/apps
    Exempel: https://contoso.crm.dynamics.com/apps

  3. Leta upp den app som du vill att användaren ska använda och välj ellipsalternativet (...) och välj sedan Hantera roller.

    Obs!

    Alternativet ... visas bara i appar av typen Enhetligt gränssnitt som är de enda appar som stöds för användning med Dynamics 365 för telefoner och surfplattor. Om du inte redan har en enhetlig gränssnittsapp kan du använda alternativet Skapa ny app .

  4. En lista över Dynamics 365 säkerhetsroller visas. Kontrollera att minst en roll som tilldelats användaren är markerad och välj sedan Spara.

Mer information finns i Hantera åtkomst till appar med hjälp av säkerhetsroller.

Lösning 2: Kontrollera att användarens roll innehåller den modelldrivna appprivilegiet

  1. Få åtkomst till Dynamics 365 webbappen som en användare med säkerhetsrollen Systemadministratör.
  2. Gå till Inställningar, välj Säkerhet och välj sedan Säkerhetsroller.
  3. Öppna rollen som tilldelats användaren.
  4. Välj fliken Anpassning och leta upp den modelldrivna appprivilegiet . Kontrollera att rollen innehåller minst läsbehörighet för den här behörigheten.
  5. Välj Spara och stäng.