Dela via


Autentiseringsproblem vid anslutning till Salesforce CRM

Den här artikeln hjälper dig att felsöka och lösa autentiseringsproblem när du ansluter till Salesforce CRM från tillägget Microsoft Copilot for Sales för Outlook.

Obs!

Microsoft Sales Copilot byter namn till Microsoft Copilot for Sales i januari 2024. Skärmbilderna i den här artikeln kommer snart att uppdateras med det nya namnet.

Vem påverkas?

Typ av krav Beskrivning
Klientapp Copilot for Sales Outlook-tillägg och Teams-app
Plattform Webb- och skrivbordsklienter
OS Windows och Mac
Distribution Användarhanterad och administratörshanterad
CRM Salesforce
Användare Användare som försöker logga in på Salesforce CRM

Symptom

När du försöker logga in på Salesforce CRM från Copilot for Sales-tillägget för Outlook visas följande felmeddelande:

Det gick inte att skicka omdirigerings-URL:en. error=OAUTH_APP_ACCESS_DENIED error_description=user is not admin approved to access this app

Skärmbild som visar autentiseringsfelet.

Orsak

Principer för den Microsoft Power Platform-anslutna appen hindrar användare från att ansluta till Salesforce CRM.

Copilot for Sales ansluter till Salesforce CRM via den Microsoft Power Platform-anslutna appen. För att logga in på Salesforce CRM från Copilot for Sales måste användarna ge sitt medgivande till Microsoft Power Platform-appen för att kontakta Salesforce CRM för deras räkning. När medgivande inte kan anges misslyckas inloggningsprocessen.

Åtgärd

Copilot for Sales använder den Microsoft Power Platform-anslutna appen för att ansluta till Salesforce CRM. Se till att principerna för Microsoft Power Platform-appen är konfigurerade så att användarna kan ansluta till Salesforce CRM.

  1. Logga in på Salesforce CRM som administratör.

  2. Gå till Konfigurera>plattformsverktyg>Appar>Anslutna appar>Hanterade anslutna appar.

  3. På sidan Anslutna appar väljer du Microsoft Power Platform.

    Skärmbild som visar sidan Anslutna appar.

  4. Välj Redigera principer.

  5. Under OAuth-principer väljer du något av följande värden för Tillåtna användare:

    Skärmbild som visar värdena för tillåtna användare.

    1. Alla användare kan själv auktorisera: Med det här alternativet kan alla autentiserade Salesforce-användare ansluta till Salesforce-instansen via Microsoft Power Platform-anslutningsappen som används av Microsoft Copilot for Sales, Microsoft Power Automate och potentiellt andra appar för att få åtkomst till Salesforce, vilket löser problemet.

    2. Admin godkända användare är förauktoriserade: Med det här alternativet kan administratörer uttryckligen bevilja behörigheter till enskilda användare via profiler och behörighetsuppsättningar. Mer information finns i Anslutna appar och Hantera åtkomst till en ansluten app.

      Skärmbild som visar avsnitten Profiler och Behörighetsuppsättningar.

  6. Välj Spara.

Mer information

Om problemet fortfarande är olöst går du till Copilot for Sales – Microsoft Community Hub för att kontakta våra experter.

Ansvarsfriskrivning för information från tredje part

De produkter från andra tillverkare som diskuteras i denna artikel tillverkas oberoende av Microsoft. Produkternas funktion eller tillförlitlighet kan därför inte garanteras.