Anteckning
Åtkomst till den här sidan kräver auktorisering. Du kan prova att logga in eller ändra kataloger.
Åtkomst till den här sidan kräver auktorisering. Du kan prova att ändra kataloger.
Den här artikeln hjälper dig att lösa problemet där åtkomsttjänsten för mänskligt gränssnitt eller HID-indatatjänsten inte kan starta i Windows Embedded för Point of Service.
Ursprunglig produktversion: Human Interface Device Access Service, HID Input Service
Ursprungligt KB-nummer: 2009753
Symptom
Åtkomsttjänsten för mänskligt gränssnitt eller HID-indatatjänsten kan inte startas på Windows Embedded för point of service. SCM ID 7023-felet visas i händelseloggen.
Den här tjänsten som saknas kan vara rotorsaken till att en Windows Embedded för point of service-fel räkna upp Bluetooth-enheter. Det kan också leda till fel på vanliga POS HID-enheter, till exempel skannrar, magnetiska bandläsare och annan kringutrustning som förlitar sig på HID-indatatjänsten för att ansluta till ett Windows Embedded for Point of Service-system.
Orsak
Om det inte finns någon HID-enhet ansluten under installationen av Windows Embedded for Point of Service kanske den HIDSERV.DLL filen inte installeras i systemet, vilket hindrar HID-tjänsten från att starta. Om HID-enheter senare läggs till i Windows Embedded för point of service-systemet, eller om andra funktioner som är beroende av HID-tjänsten krävs, hindrar hid-tjänstens fel dem från att fungera.
Åtgärd
Om HID-indatatjänsten eller de underliggande Bluetooth-beroendena inte är krav för Windows Embedded för point of service-systemet kan tjänsten inaktiveras för att rensa felrapportering i händelseloggen.
Om HID-indatatjänsten krävs installerar du filen som saknas genom att följa stegen nedan för att starta tjänsten.
- Bläddra till mappen
%systemroot%\i386
. - Dubbelklicka på sp2.cab-filen. De komprimerade filerna i .cab-filen visas.
- Kopiera hidserv.dll-filen till
%systemroot%\system32
mappen. - Starta om HID-indatatjänsten eller starta om datorn.