Redigera

Dela via


Bug Check 0x79: MISMATCHED_HAL

The MISMATCHED_HAL bug check has a value of 0x00000079. This bug check indicates that the Hardware Abstraction Layer (HAL) revision level or configuration does not match that of the kernel or the computer.

Important

This article is for programmers. If you're a customer who has received a blue screen error code while using your computer, see Troubleshoot blue screen errors.

MISMATCHED_HAL Parameters

Parameter 1 indicates the type of mismatch.

Parameter 1 Parameter 2 Parameter 3 Parameter 4 Cause.

0x1

The major processor control block (PRCB) level of Ntoskrnl.exe.

The major PRCB level of Hal.dll.

Reserved

The PRCB release levels are mismatched. (Something is out of date.)

0x2

The build type of Ntoskrnl.exe.

The build type of Hal.dll.

Reserved

The build types are mismatched.

0x3

The size of the loader parameter extension.

The major version of the loader parameter extension.

The minor version of the loader parameter extension.

The loader (ntldr) and HAL versions are mismatched.

When Parameter 1 equals 0x2, the following build type codes are used:

  • 0: Multiprocessor-enabled free build

  • 1: Multiprocessor-enabled checked build

  • 2: Single-processor free build

  • 3: Single-processor checked build

Cause

The MISMATCHED_HAL bug check often occurs when a user manually updates Ntoskrnl.exe or Hal.dll.

The error can also indicate that one of those two files is out of date. Or the computer might erroneously have a multiprocessor HAL and a single-processor kernel installed, or vice versa.

The Ntoskrnl.exe kernel file is for single-processor systems and Ntkrnlmp.exe is for multiprocessor systems. However, these file names correspond to the files on the installation media.After you have installed the Windows operating system, the file is renamed to Ntoskrnl.exe, regardless of the source file that is used. The HAL file also uses the name Hal.dll after installation, but there are several possible HAL files on the installation media on older versions of Windows.

Resolution

Restart the computer by using the product CD or the Windows Setup disks. At the Welcome screen, press F10 to start the Recovery Console. Use the Copy command to copy the correct HAL or kernel file from the original CD into the appropriate folder on the hard disk. The Copy command detects whether the file that you are copying is in the Microsoft compressed file format. If so, it automatically expands the file that is copied on the target drive.