"Fix mailbox errors in Dynamics 365" error occurs when saving an email or a meeting
This article helps you troubleshoot and resolve the "Fix mailbox errors in Dynamics 365" error when you use Microsoft Copilot for Sales in Outlook.
Note
Microsoft Sales Copilot is rebranded as Microsoft Copilot for Sales in January 2024. The screenshots in this article will be updated with the new name soon.
Who is affected?
Requirement type | Description |
---|---|
Client app | Copilot for Sales Outlook add-in |
Platform | Web and desktop clients |
OS | Windows and Mac |
Deployment | User managed and admin managed |
CRM | Dynamics 365 |
Users | All users |
Symptoms
When you open Copilot for Sales in Outlook and try to save an email or a meeting to Microsoft Dynamics 365, you see the following error message:
Fix mailbox errors in Dynamics 365
Cause
This issue occurs because one or more sync errors occur in server-side synchronization.
Copilot for Sales requires server-side synchronization to synchronize emails and meetings to Dynamics 365. When server-side synchronization encounters an error while attempting the synchronization, Copilot for Sales detects and displays this error message for you to take action and resolve the error.
Resolution
To resolve the error, you must locate the specific error as part of the mailbox alert wall, read the description, and take action. You can also delete the error to suppress it.
Open the CRM instance you connected to Copilot for Sales.
Note
To get the CRM instance URL, select Options (…) in the upper-right corner of the Copilot for Sales pane. The URL is displayed under Signed in to Dynamics 365.
Select Settings > Personalization Settings.
Select the Email tab, and then select View your Mailbox.
Select Alerts in the left pane, and then select Errors to see errors related to the mailbox.
Each error has a description and a link to an article that helps you resolve the error. You can also delete the error to suppress it.
Note
Deleting an error resets the mailbox state. The error might reappear during the next synchronization if the underlying issue isn't resolved.
Resolve and clear errors to restore the save to CRM functionality in Copilot for Sales.
More information
If your issue is still unresolved, go to the Copilot for Sales - Microsoft Community Hub to engage with our experts.