Hızlı başlangıç: Visual Studio'da bir Stream Analytics işi yaratın

Bu hızlı başlangıçta, Visual Studio için Azure Stream Analytics araçlarını kullanarak bir Stream Analytics işi oluşturuyorsunuz. Örnek iş, bir IoT hub cihazından akış verilerini okur. Değer 27°'nin üzerinde ortalama sıcaklığı hesaplayan ve ortaya çıkan çıktı olaylarını blob depolamadaki yeni bir dosyaya yazan bir iş tanımlarsınız.

Prerequisites

Başlamadan önce, aşağıdaki ön koşulları sağladığınızdan emin olun.

Uyarı

En iyi yerel geliştirme deneyimi için Visual Studio Code için Stream Analytics araçlarını kullanın. Visual Studio 2019 için Stream Analytics araçları (sürüm 2.6.3000.0) bilinen özellik boşluklarına sahip ve daha fazla iyileştirme almıyor. Visual Studio ve Visual Studio Code araçları Doğu Çin, Kuzey Çin, Orta Almanya ve Almanya NorthEast bölgelerindeki işleri desteklemez.

Girdi verilerini hazırlama

Stream Analytics işini tanımlamadan önce, daha sonra iş girişi olarak yapılandırdığınız verileri hazırlayın. Giriş verilerini hazırlamak için aşağıdaki adımları tamamlayın:

  1. Azure portalınaoturum açın.

  2. Kaynak oluştur>Nesnelerin İnterneti>IoT Hub'ı seçin.

  3. IoT Hub bölmesine aşağıdaki bilgileri girin:

    Setting Önerilen değer Açıklama
    Subscription <Aboneliğiniz> Kullanmak istediğiniz Azure aboneliğini seçin.
    Kaynak grubu asaquickstart-resourcegroup Yeni Oluştur'u seçin ve hesabınız için yeni bir kaynak grubu adı girin.
    IoT Hub Adı MyASAIoTHub IoT merkeziniz için bir isim seçin.
    Bölge <Kullanıcılarınıza en yakın bölgeyi seçin> IoT merkezinizi barındırabileceğiniz coğrafi bir konum seçin. Kullanıcılarınıza en yakın konumu kullanın.
    Katman Ücretsiz Bu hızlı başlangıç için aboneliğinizde hala kullanılabiliyorsa Ücretsiz'i seçin. Ücretsiz katman kullanılamıyorsa, kullanılabilir en düşük katmanı seçin. Daha fazla bilgi için bkz. IoT Hub fiyatlandırması.

    Azure portalında IoT Hub Oluşturma sihirbazını gösteren ekran görüntüsü.

  4. Seçin, gözden geçir ve oluştur. IoT hub bilgilerinizi gözden geçirin ve Oluştur'u seçin. IoT hub'ınızı oluşturmak birkaç dakika sürebilir. Bildirimler bölmesinde ilerleme durumunu izleyin.

  5. Dağıtım tamamlandıktan sonra, IoT hub'ınız için IoT hub sayfasına gitmek için Kaynağa Git ' seçeneğini seçin.

  6. IoT Hub sayfasında, sol gezinti menüsündeki Cihaz yönetimi'nin altında Cihazlar'ı seçin.

  7. Cihazlar sayfasında araç çubuğunda + Cihaz ekle'yi seçin.

    Cihaz ekle'nin seçili olduğu Cihazlar sayfasını gösteren ekran görüntüsü.

  8. Cihaz oluştur sayfasında cihaz için bir ad girin ve Kaydet'i seçin.

    Cihaz oluştur sayfasını gösteren ekran görüntüsü.

  9. Cihazı oluşturduktan sonra, IoT cihazları listesinden açın. Cihazı henüz görmüyorsanız sayfayı yenileyin.

    Oluşturduğunuz cihazın yer aldığı cihaz listesini gösteren ekran görüntüsü.

  10. Birincil bağlantı dizesini kopyalayın ve daha sonra kullanmak üzere bir not defterine kaydedin.

Blob depolama oluşturma

Bu bölümde, işinizden çıkan çıktı olaylarını depolamak için bir Azure Depolama hesabı ve blob konteyneri oluşturuyorsunuz.

  1. Azure portalının sol üst köşesinden Bir kaynak oluşturun>Depolama>Depolama hesabı'nı seçin.

  2. Depolama hesabı oluştur bölmesinde bir depolama hesabı adı, konumu ve kaynak grubu girin. Oluşturduğunuz IoT Hub ile aynı konumu ve kaynak grubunu seçin. Ardından gözden geçir + oluştur'u seçerek hesabı oluşturun.

    Azure portalında Depolama hesabı oluştur sayfasını gösteren ekran görüntüsü.

  3. Depolama hesabınızı oluşturduktan sonra, Genel Bakış panelinde Blob servis kutusunu seçin.

    Blob hizmetinin seçili olduğu Depolama hesabına genel bakış sayfasını gösteren ekran görüntüsü.

  4. Blob hizmeti sayfasında araç çubuğunda + Kapsayıcı'yı seçin.

  5. Yeni kapsayıcı sayfasında kapsayıcınız için kapsayıcı1 gibi bir ad girin. Genel erişim düzeyiniÖzel (anonim erişim yok) olarak bırakın ve Oluştur'u seçin.

    Yeni kapsayıcı sayfasını gösteren ekran görüntüsü.

Stream Analytics projesi oluşturma

İşin girdilerini, çıktılarını ve sorgularını tanımlamak için Visual Studio'da bir Stream Analytics projesi oluşturun.

  1. Visual Studio'yu başlatın.

  2. Dosya>Yeni Proje seçin.

  3. Şablonlar listesinde Stream Analytics seçin, ardından Azure Stream Analytics Application'ı seçin.

  4. Proje Adı, Konum ve Çözüm adını girin ve Oluştur'u seçin.

    Bir Akış Analizi Oluştur projesi diyalog kutusunu gösteren ekran görüntüsü.

  5. Bir Azure Stream Analytics projesindeki öğelere dikkat edin.

    Visual Studio'da örnek bir Stream Analytics uygulama projesi için Çözüm Gezgini penceresini gösteren ekran görüntüsü.

Gerekli aboneliği seçin

Visual Studio'yu, oluşturduğunuz kaynakları içeren Azure aboneliğine bağlayın.

  1. Visual Studio'da Görünüm menüsünde Sunucu Gezgini'ni seçin.
  2. Azure'u seçin ve basılı tutun (veya sağ tıklayın), Microsoft Azure Aboneliği'ne Bağlan'ı seçin ve ardından Azure hesabınızla giriş yapın.

Girişi tanımlama

İş girdisini, oluşturduğunuz IoT hub'dan akış verisini okuyacak şekilde ayarlayın.

  1. Çözüm Gezgini'deInputs düğümünü genişletin ve Input.jsonaçın.

  2. Stream Analytics Giriş Yapılandırması'nı aşağıdaki değerlerle doldurun:

    Setting Önerilen değer Açıklama
    Giriş Diğer Adı Veri Girişi İşin girdisini belirlemek için bir isim girin.
    Kaynak Türü Veri Akışı Uygun giriş kaynağını seçin: Veri Akışı veya Başvuru Verileri.
    Kaynak IoT Hub Uygun giriş kaynağını seçin.
    Resource Geçerli hesaptan veri kaynağı seçme Verileri el ile girmeyi veya mevcut bir hesabı seçmeyi seçin.
    Subscription <Aboneliğiniz> Oluşturduğunuz IoT hub'ını içeren Azure aboneliğini seçin.
    IoT Hub MyASAIoTHub IoT merkezinizin adını seçin veya girin. IoT hub isimleri aynı abonelikte oluşturduğunuzda otomatik olarak görünür.
  3. Diğer seçenekleri varsayılan değerlere bırakın ve ayarları kaydetmek için Kaydet'i seçin.

    Stream Analytics Giriş Yapılandırması sayfasını gösteren ekran görüntüsü.

Çıktıyı tanımlama

İş çıktısını blob depolama konteynerinize sonuçları yazacak şekilde ayarlayın.

  1. Çözüm Gezgini'deOutputs düğümünü genişletin ve Output.jsonaçın.

  2. Stream Analytics Çıkış Yapılandırması'nı aşağıdaki değerlerle doldurun:

    Setting Önerilen değer Açıklama
    Çıkış Takma Adı Çıktı İşin çıktısını belirlemek için bir isim girin.
    Lavabo Data Lake Storage 2. Nesil/Blob Depolama Uygun havuzu seçin.
    Resource Veri kaynağı ayarlarını el ile sağlama Verileri el ile girmeyi veya mevcut bir hesabı seçmeyi seçin.
    Subscription <Aboneliğiniz> Oluşturduğunuz depolama hesabının yer aldığı Azure aboneliğini seçin. Depolama hesabı aynı veya farklı bir abonelikte olabilir. Bu örnek, aynı abonelikte bir depolama hesabı oluşturduğunuzu varsayıyor.
    Depolama Hesabı asaquickstartstorage Depolama hesabının adını seçin veya girin. Depolama hesap isimleri aynı abonelikte oluşturduğunuzda otomatik olarak görünür.
    Container kapsayıcı1 Depolama hesabınızda oluşturduğunuz mevcut kapsayıcıyı seçin.
    Yol Deseni output Konteyner içinde oluşturulacak dosya yolunun adını girin.
  3. Diğer seçenekleri varsayılan değerlere bırakın ve ayarları kaydetmek için Kaydet'i seçin.

    Stream Analytics Çıkış Yapılandırması sayfasını gösteren ekran görüntüsü.

Dönüşüm sorgusunu tanımlama

Akış verisini filtreleyen ve sonuçları çıktıya gönderen bir sorgu tanımlayın.

  1. Visual Studio'da Çözüm Gezgini'ndenScript.asaql dosyasını açın.

  2. Aşağıdaki sorguyu ekleyin:

    SELECT *
    INTO Output
    FROM Input
    WHERE Temperature > 27
    

Azure'a Stream Analytics sorgusu gönderme

Stream Analytics işini oluşturmak için sorguyu Azure'a gönderin.

  1. Sorgu Düzenleyicisi'nde betik düzenleyicisinde Azure'a Gönder'i seçin.

  2. İşi Gönder penceresinde Yeni Azure Stream Analytics işi oluştur'u seçin.

  3. Bir İş Adı girin.

  4. Azure Aboneliği'ni seçin.

  5. Kaynak Grubunu seçin.

  6. Küme için varsayılan değeri koruyun.

  7. Hızlı başlatmanın başında kullandığınız Konumu seçin.

  8. Gönderseçin.

    İşi Gönder iletişim kutusunu gösteren ekran görüntüsü.

IoT simülatörünü çalıştırma

Örnek sensör verisini IoT hub'ınıza göndermek için Raspberry Pi simülatörü çalıştırın.

  1. Raspberry Pi Azure IoT Online Simülatörü'ni yeni bir tarayıcı sekmesinde veya penceresinde açın.

  2. 15. satırdaki yer tutucuyu önceki bölümde kaydettiğiniz Azure IoT Hub cihaz bağlantı dizesiyle değiştirin.

  3. Çalıştır'ı seçin. Çıkış, sensör verilerini ve IoT hub'ınıza gönderilen mesajları göstermelidir.

    Raspberry Pi Azure IoT Online Simülatörünü gösteren ekran görüntüsü.

Stream Analytics işini başlatın ve çıktıyı kontrol edin.

İşi başlatın ve giriş olaylarını işlediğini ve çıktıyı blob depolamaya yazdığını doğrulayın.

  1. İşinizi oluşturduğunuzda, iş görünümü otomatik olarak açılır. İşi başlatmak için yeşil ok düğmesini seçin.

    Visual Studio'dan bir Stream Analytics işi başlatmak için Başlat düğmesini gösteren ekran görüntüsü.

  2. İş çıktısı başlangıç modunuJobStartTime olarak değiştirin ve Başlat'ı seçin.

    Stream Analytics İş Yapılandırmasını Başlat iletişim kutusunu gösteren ekran görüntüsü.

  3. İş durumu Çalışıyor olarak değişir ve giriş ile çıkış olayları görünür. Bu değişiklik birkaç dakika sürebilir. Ölçümleri yenilemek için araç çubuğundaki Yenile düğmesini seçin.

    İş durumunu çalışıyor olarak ve işin ölçümlerini gösteren ekran görüntüsü.

  4. Sonuçları görmek için Görünüm menüsünden Cloud Explorer'ı seçin ve kaynak grubunuzdaki depolama hesabına gidin. Blob Containers altında container1 öğesini, ardından output dosya yolunu açın.

    container1 blob kapsayıcısındaki çıktı sonuçlarını gösteren ekran görüntüsü.

Kaynakları temizle

Artık ihtiyacınız olmadığında kaynak grubunu, yayın işini ve ilgili tüm kaynakları silin. Görevin silinmesi, tükettiği akış birimleri için faturalandırmayı durdurur. Gelecekte işi kullanmayı planlıyorsanız, durdurun ve ihtiyacınız olduğunda tekrar başlatın. Bu işi tekrar kullanmayı planlamıyorsanız, bu hızlı başlangıç'ın oluşturduğu tüm kaynakları silmek için aşağıdaki adımları kullanın:

  1. Azure portalındaki sol menüden Kaynak grupları seçeneğini seçin ve oluşturduğunuz kaynağın adını seçin.
  2. Kaynak grubu sayfanızda Sil'i seçin, metin kutusuna silinecek kaynağın adını yazın ve sil'i seçin.