Not
Bu sayfaya erişim yetkilendirme gerektiriyor. Oturum açmayı veya dizinleri değiştirmeyi deneyebilirsiniz.
Bu sayfaya erişim yetkilendirme gerektiriyor. Dizinleri değiştirmeyi deneyebilirsiniz.
Şunlar için geçerlidir: ✔️ Windows VM'leri
Bu makalede, sanal makinenin (VM) Windows'u yüklerken beklenmeyen bir yeniden başlatma veya hatayla karşılaşması sorunlarını çözmeye yönelik adımlar sağlanır.
Belirti
VM'nin ekran görüntüsünü görüntülemek için Önyükleme tanılamasını kullandığınızda ekran görüntüsünde Windows yüklemesinin aşağıdaki hatayla başarısız olduğunu görürsünüz:
Bilgisayar beklenmedik bir şekilde yeniden başlatıldı veya beklenmeyen bir hatayla karşılaştı. Windows yüklemesi devam edemiyor. Windows'u yüklemek için bilgisayarı yeniden başlatmak için "Tamam"a tıklayın ve yüklemeyi yeniden başlatın.
Neden
Makine genelleştirilmiş bir görüntünün ilk önyüklemesini yapmaya çalışır, ancak işlenen özel yanıt dosyası (Unattend.xml) nedeniyle sorunlarla karşılaşır. Özel yanıt dosyaları Azure'da desteklenmez.
Yanıt dosyası, Windows Server işletim sistemi yüklemesi sırasında otomatikleştirmek istediğiniz yapılandırma ayarları için ayar tanımlarını ve değerlerini içeren özel bir XML dosyasıdır. Yapılandırma seçenekleri diskleri bölümleme, yüklenecek Windows görüntüsünün nerede bulunacağı, uygulanacak ürün anahtarları ve çalıştırmak istediğiniz diğer komutları içerir.
Azure'da özel yanıt dosyaları da desteklenmez. Bu nedenle, bir görüntü Azure'da kullanılmak üzere hazırlandıysa, ancak aşağıdaki komuta benzer bir bayrakla SYSPREP kullanarak özel bir Unattend.xml dosyası belirttiyseniz bu durum oluşur:
sysprep /oobe /generalize /unattend:<your file's name> /shutdown
Azure'da, Sistem Hazırlama aracı GUI'sinde Sistem Hazır Deneyimi (OOBE) gir seçeneğini kullanın veya Unattend.xml dosyası yerine kullanınsysprep /oobe
.
Bu sorun genellikle genelleştirilmiş bir VM'yi Azure'a yüklemek için bir şirket içi VM ile sysprep kullanırken oluşturulur. Bu durumda, genelleştirilmiş bir VM'yi düzgün bir şekilde karşıya yüklemeyle de ilgilenebilirsiniz.
Çözüm
VM'yi yedekten geri yüklemeyi deneyin
VM'nin yeni bir yedeğine sahipseniz önyükleme sorununu çözmek için VM'yi yedeklemeden geri yüklemeyi deneyebilirsiniz. VM'yi yedeklemeden geri yüklemek mümkün değilse, Unattend.xml kullanma bölümündeki adımları izleyin.
Unattend.xml kullanmayın
Bu sorunu çözmek için, bir görüntüyü hazırlama/yakalama ve yeni bir genelleştirilmiş görüntü hazırlama ile ilgili Azure kılavuzunu izleyin. Sysprep sırasında bayrağı kullanmayın/unattend:<your file's name>
. Bunun yerine yalnızca aşağıdaki bayrakları kullanın:
sysprep /oobe /generalize /shutdown
- İlk çalıştırma deneyimi (OOBE), Azure VM'leri için desteklenen ayardır.
Aşağıdaki seçenekleri belirleyerek önceki komutla aynı görevi gerçekleştirmek için Sistem Hazırlama aracı GUI'sini de kullanabilirsiniz:
- yerleşik deneyim girin
- Genelleştir
- Kapat
Yardım için bize ulaşın
Sorularınız veya yardıma ihtiyacınız varsa bir destek isteği oluşturun veya Azure topluluk desteği isteyin. Ürün geri bildirimini Azure geri bildirim topluluğuna da gönderebilirsiniz.