Aracılığıyla paylaş


Sistem yöneticileri için müşteri adayı niteliğiyle ilgili sorunları giderme

Sorun 1 - Kullanıcı müşteri adaylarını nitelemeye çalışırken izin yetersiz veya Erişim reddedildi hatası

Bu hatayı nasıl çözeceğiniz, müşteri adayı kayıtları için aşağıdaki sahiplik senaryolarına bağlıdır.

Sahiplik senaryosu Çözüm adımları
Müşteri adayı, bu müşteri adayını nitelemeye çalışan kullanıcıya aittir.
  1. Sistem yöneticisi rolüne veya eşdeğer izinlere sahip olduğunuzdan emin olun.
  2. Ayarlar>Güvenlik Rolü'ne gidin.
  3. Kullanıcının güvenlik rolünü açın.
  4. Çekirdek Kayıtlar sekmesinde, aşağıdaki varlıklardaki Kullanıcı düzeyinde Güvenlik Rolüne Oluşturma, Okuma, Ekleme ve Ekleme izinlerini atayın:
    • Hesabı
    • Kurşun
    • Kişi
    • Fırsat
    Kullanıcı düzeyinde erişime sahip güvenlik rolü.

  5. Özel Varlıklar sekmesinde, herhangi bir özel varlığa Okuma erişimi atayın.
  6. Özelleştirmeler sekmesinde Öznitelik Eşlemesi, Özelleştirmeler, Varlık ve Varlık Eşlemesi'ne Okuma erişimi atayın.
Kullanıcının nitelemeye çalıştığı müşteri adayı kendi iş birimindedir.
  1. Ayarlar>Güvenlik Rolü'ne gidin.
  2. Kullanıcının güvenlik rolünü açın.
  3. Aşağıdaki varlıklarda İş Birimi düzeyinde kullanıcının Güvenlik Rolüne Oluşturma, Okuma, Ekleme ve Ekleme izinleri atayın:
    • Hesabı
    • Kurşun
    • Kişi
    • Fırsat
    İş Birimi düzeyinde erişime sahip güvenlik rolü.
  4. Herhangi bir özel varlığa Okuma erişimi atayın.
  5. Öznitelik Eşlemesi, Özelleştirmeler, Varlık ve Varlık Eşlemesi'ne Okuma erişimi atayın.
Kullanıcının nitelemeye çalıştığı müşteri adayı kendi kuruluşundadır.
  1. Ayarlar>Güvenlik Rolü'ne gidin.
  2. Kullanıcının güvenlik rolünü açın.
  3. Aşağıdaki varlıklarda Kuruluş düzeyinde kullanıcının Güvenlik Rolüne Oluşturma, Okuma, Ekleme ve Ekleme izinleri atayın:
    • Hesabı
    • Kurşun
    • Kişi
    • Fırsat
    Kuruluş düzeyinde erişime sahip güvenlik rolü.
  4. Herhangi bir özel varlığa Okuma erişimi atayın.
  5. Öznitelik Eşlemesi, Özelleştirmeler, Varlık ve Varlık Eşlemesi'ne Okuma erişimi atayın.

Müşteri adayının niteliği sırasında, (isteğe bağlı olarak) oluşturulan kayıtlar şunlardır: Fırsat, İlgili Kişi ve Firma. Daha fazla bilgi için bkz . Müşteri adaylarını niteleme veya dönüştürme.

Kullanıcı, bu bölümde daha önce belirtildiği gibi uygun ayrıcalıkları atadıktan sonra bile ayrıcalıkla ilgili hatalar alıyorsa, hesap, kişi veya fırsat kayıtları oluşturulurken erişilmekte olan bazı varlıklarda ayrıcalıkları eksik olabilir. Örneğin, bazı eklentiler veya iş akışları hesap, kişi veya fırsat varlıklarının bazı işlemlerinde çalıştırıldığında erişilen bazı özel varlıklarda kullanıcının ayrıcalıkları eksik olabilir.

Bu sorunu daha fazla gidermek için şu adımları izleyin:

  1. Sorunu Fırsat, Firma veya İlgili Kişi kaydı oluşturmak için yalıtın: Kullanıcıdan Firma, İlgili Kişi ve Fırsat kayıtlarını tek tek oluşturmayı denemesini isteyin ve bu kayıtların oluşturulmasında ayrıcalıkla ilgili aynı sorunu alıp almadıklarını görün. Bir veya daha fazla kayıt türünde ayrıcalık sorunları olabilir, bu nedenle her kayıt türü için bu adımın gerçekleştirilmesi önemlidir. Örneğin, Hesap ve İlgili Kişi varlıklarında uygun ayrıcalıklara sahip olmayabilirler.

  2. Varlık oluşturulurken kaydedilen herhangi bir eklentinin/iş akışının sorunlara neden olup olmadığını belirleyin: Sorunu belirli bir varlık kaydı oluşturmak üzere yalıtdıktan sonra, bu varlık kayıtlarını oluştururken çalışan herhangi bir eklentinin veya iş akışının, geçerli kullanıcının ayrıcalıkları eksik olduğu diğer bazı varlıklara erişip erişmediğini denetleyin. Bunun için, varlık kayıtlarının oluşturulması üzerine kaydedilen tüm eklentileri veya iş akışlarını bulun ve soruna neden olan eklentiyi veya iş akışını belirlemek için bunları tek tek devre dışı bırakın. Soruna neden olan eklentiyi veya iş akışını tanımladıktan sonra kayıt oluşturma işleminin engelini kaldırmak için eklentiyi devre dışı bırakın. Bir varlık için kaydedilen tüm iş akışlarını tanımlama hakkında daha fazla bilgi için bkz. Özel iş akışı işlemini devre dışı bırakma.

Varlık kaydı oluşturulurken kaydedilen eklentileri tanımlama hakkında daha fazla bilgi için bkz. Özel eklentiyi devre dışı bırakma.

Sorun 2 - Müşteri adayı kaydında "Müşteri adayını nitele" komutu kullanılamıyor

Neden

Hazır gelen Müşteri Adayı Nitele komutu, Müşteri Adayı formunda yalnızca Firma, İlgili Kişi, Müşteri Adayı ve Fırsat varlıkları Birleşik Arabirimde düzenlenebilir olarak ayarlandıysa ve Hesap, Kişi ve Fırsat varlıkları Mobil çevrimdışı olarak kullanılabiliyorsa görünür.

Çözüm

Müşteri adayını nitele komutu kullanılamıyorsa aşağıdakileri denetleyin:

  • Hesap, Kişi, Müşteri Adayı veya Fırsat varlıkları mobil cihazlar için salt okunur olarak ayarlanır. Varsa, varlığın Birleşik Arabirim için düzenlenebilir hale gelmesi için varlık özelleştirmesindeki Mobil cihazlarda salt okunur onay kutusunu temizleyin. Daha fazla bilgi için bkz. Birleşik Arabirim ile ilgili sorunları giderme.
  • Firma, İlgili Kişi ve Fırsat varlıklarının mobil çevrimdışı profilin parçası olup olmadığını denetleyin. Yoksa, bu varlıkları profile ekleyin ve değişiklikleri yayımlayın. Daha fazla bilgi için bkz . Mobil çevrimdışı eşitleme için varlıkları etkinleştirme.