How to remove duplicate folders in Outlook when connected to an Exchange Server mailbox
Symptoms
In Microsoft Outlook, you see duplicate folders in your Microsoft Exchange Server mailbox when you view the Outlook folder list, or when you view the folder list by using Outlook Web App (OWA).
Cause
A mobile device or a third-party server application that synchronizes with the Exchange Server mailbox may unexpectedly introduce the duplication. Or, the unexpected duplication may be the result of Exchange Server mailbox maintenance or of other changes that are performed on the computer that is running Exchange Server. Other factors could also contribute to the issue described in the Symptoms section of this article.
Resolution
The following steps may result in data loss if you do not follow them exactly as written. We recommend that you back up Outlook data or make sure that the Exchange Server mailbox has been backed up before you proceed with these steps.
To delete the duplicate items, follow these steps:
Exit Outlook and close OWA on all workstations that are connected to the user mailbox.
Use MFCMapi to identify the duplicate folders. To do this, follow these steps:
- Download MFCMAPI (scroll down and then select Latest release).
- Run MFCMAPI.exe.
- Select the Tools menu, then select Options.
- Enable the following option:
- Use MDB_ONLINE when calling OpenMsgStore
- Select OK.
- On the Session menu, select Logon.
- If you are prompted for a profile, select your profile name, and then select OK.
- In the top pane, locate the line that corresponds to your mailbox, and double-click it.
- In the navigation pane (left-side pane), expand Root Container, and then expand Top of Information Store.
- To identify the duplicate folder, select one of the duplicate folders on the left pane. In the right pane, locate the Value column for the
PR_CREATION_TIME
property. Compare this value to the duplicate folder with the same name. The duplicate folder will have a newer creation date and time. Work with one pair of folders at a time (for example, start with the two Calendar folders that appear).
Use MFCMAPI to copy any items from the duplicate folder to the original folder. These are items created after the duplicate folders were created. This can include email that was received in the Inbox, Contacts that were created, Calendar appointments that you scheduled and meetings that you accepted.
In the left pane of MFCMAPI, double-click on the duplicate folder, which has the newer creation date and time.
On the window that opens, select the top pane, then press CTRL+A to select all items.
If no items appear in the top pane, the folder is already empty; skip to step 7.
Select the Actions menu, then select the Copy Messages command.
Close the folder window, then double-click on the original folder, which has the older creation date and time.
Select the Actions menu, then select the Paste Messages command.
Enable the MESSAGE_MOVE checkbox, then select OK.
Close the folder window.
In MFCMAPI, switch back to the duplicate folder, which is now empty. Use MFCMAPI to delete it.
- Right-click the duplicate folder, and then select Delete Folder.
- Enable the Hard Deletion option, and then select OK.
Repeat steps 2 through 4 for other common Outlook folders (Contacts, Deleted Items, Drafts, Inbox, Journal, Junk E-mail, Notes, Sent Items, and Tasks).
Close MFCMAPI.
Start Outlook with the
resetfolders
switch:Open the Run dialog box. To do this, use one of the following procedures, as appropriate for your version of Windows.
Windows 10, Windows 8.1 and Windows 8: Press Windows Key+R.
Windows 7 and Windows Vista: Select the Start button, point to All Programs, select Accessories, and then select Run.
Windows XP: Select the Windows Start button, and then select Run.In the Run dialog box, type the following, and then select OK :
Outlook.exe /resetfolders
More information
For more information about command-line switches in Outlook, see Command-line switches for Microsoft Office products