無法在 Microsoft Dynamics 365 中建立電子郵件,並出現 NoRecipientMatch 同步處理錯誤

適用於:Microsoft Dynamics 365
原始 KB 編號: 4339830

徵狀

檢閱由 Microsoft Dynamics 365 自動升級所分析的電子郵件訊息時,您會看到無法在 Microsoft Dynamics 365 中建立的電子郵件訊息,並出現 NoRecipientMatch 同步處理錯誤或錯誤碼 -2147218683

原因

當 Microsoft Dynamics 365 評估信箱中的電子郵件時,系統會評估多個條件,以判斷是否應該在 Microsoft Dynamics 365 中自動將郵件建立為電子郵件活動。 如果評估導致 NoRecipientMatch 錯誤,這表示下列其中一個條件:

  1. 電子郵件的 [寄件人] 或 [副本] 行上沒有任何電子郵件位址是 Microsoft Dynamics 365 中的使用者或佇列。

    • 範例 A:您收到電子郵件是因為電子郵件已傳送至通訊群組,而您是該通訊群組的成員。 您儲存在 Microsoft Dynamics 365 的電子郵件地址實際上不在電子郵件的 [寄件者] 或 [副本] 行上。
    • 範例 B:例如,您有多個電子郵件地址 (,John@contoso.comJohn.David@contoso.com相同信箱的) ,但電子郵件 [收件者] 或 [副本] 行上的電子郵件位址不符合儲存在 Microsoft Dynamics 365 中用戶記錄中的任何電子郵件位址。
  2. 電子郵件的 [寄件者] 或 [副本] 行上有使用者或佇列,但有下列條件存在:

    • 用戶或佇列所使用的電子郵件位址存在於 Microsoft Dynamics 365 中的其他記錄上。 例如:使用者有電子郵件位址 John@contoso.com ,但該電子郵件位址也存在於另一個已啟用電子郵件之實體的電子郵件位址字段上,例如使用者、佇列、連絡人、主管或帳戶。

    • 如果找到多個相符專案,您的組織會設定為將電子郵件位址值保持為無法解析。

      上述兩個條件的組合會導致電子郵件無法解析為使用者或佇列記錄。

  3. 使用者或佇列的電子郵件地址位於電子郵件副本上。

    範例:您收到電子郵件是因為您的電子郵件地址位於電子郵件的密件抄送行上。 除非您在 Microsoft Dynamics 365 中的個人選項設定為追蹤所有電子郵件訊息,否則不會追蹤電子郵件。

    除非電子郵件 [寄件者] 或 [副本] 行上的電子郵件位址符合儲存在 Microsoft Dynamics 365 的電子郵件位址,或您在 Microsoft Dynamics 365 中的個人選項設定為追蹤所有電子郵件訊息,否則不會追蹤電子郵件。

  4. 在收到電子郵件之使用者或佇列信箱的 EmailSearchBase 數據表中沒有數據列。

    尋找相符的使用者或佇列記錄時,Microsoft Dynamics 365 查詢名為 EmailSearchBase 的數據表。 此資料表應該會自動針對每個已啟用電子郵件記錄的電子郵寄地址提供一列,包括用戶和佇列。 在極少數情況下,此數據表可能會遺失數據列,而這可能會導致 Microsoft Dynamics 365 在查詢電子郵件訊息上使用者或佇列的此數據表時找不到相符的數據列。

    您可以開啟網頁瀏覽器,並使用 Microsoft Dynamics 365 Web API 來確認收到電子郵件訊息的使用者或佇列電子郵件位址是否存在數據列。 使用下列語法:

    https://<Your Organization URL>/api/data/v9.1/emailsearches?$filter=emailaddress eq '<email address of user or queue>'

    範例:https://contoso.crm.dynamics.com/api/data/v9.1/emailsearches?$filter=emailaddress eq 'John@contoso.com'

    如果未傳回任何記錄,這表示 EmailSearchBase 數據表中該電子郵件地址的數據列不存在。

解決方案

檢閱電子郵件的特性,以及您在個人電子郵件追蹤選項中設定的選項。

  1. 若要確認儲存在 Microsoft Dynamics 365 中的電子郵件地址:

    1. 流覽至 [設定],然後選取 [Email 組態]

    2. 選取 [信箱]

    3. 開啟您的信箱記錄,並確認電子郵件 [收件者] 或 [副本] 行上的電子郵件位址符合您信箱記錄中找到的電子郵件位址。

      注意事項

      如果您的信箱有多個電子郵件位址,您可以選取 [關於] 查閱,並將另一個電子郵件位址新增至用戶記錄上的其他電子郵件位址字段。

  2. 如果使用者或佇列的電子郵件位址存在於多筆記錄上 (例如,另一個使用者、佇列、潛在客戶、帳戶、聯繫人等) ,請從其他記錄中移除電子郵件位址,或將 [設定為]、[副本]、[密件抄送] 設定為 [ 如果在傳入電子郵件中找到多個相符專案時,將字段設為未解析的值 ] 變更為 [否]。 您可以流覽至 [設定]、[Email 組態],然後選取 [Email 组態設定] 來找到此設定。 在 [設定 Email 窗體選項] 區段中,如果在傳入電子郵件中找到多個相符專案,請將名為 [設定為]、[副本]、[密件抄送] 欄位的設定找出為無法解析的值。

  3. 若要檢視或變更電子郵件追蹤設定:

    1. 在 Microsoft Dynamics 365 中,選取 (右上角齒輪圖示) 設定,然後選取 [選項],以存取您的個人選項。

    2. 選取 [Email] 索引標籤。

    3. 在 [選取要在 Microsoft Dynamics 365 中追蹤的電子郵件] 區段底下,找出 [追蹤] 設定。

    4. 視需要調整選項,以控制哪些電子郵件應在 Microsoft Dynamics 365 自動追蹤。

      例如:如果您想要讓接收的每封電子郵件,不論寄件者為何,都自動建立為 Microsoft Dynamics 365 中的電子郵件活動,請選取 [所有電子郵件訊息] 選項。

    如需電子郵件相互關聯的詳細資訊,請參閱 Email 訊息篩選和相互關聯

  4. 如果在使用原因 4 中的步驟時找不到任何記錄,請遵循下列步驟:

    1. 在 Microsoft Dynamics 365 中開啟 [使用者] 或 [佇列] 記錄。
    2. 將電子郵件地址值變更為其他項目,然後選取 [ 儲存]
    3. 然後將電子郵件地址值變更回正確的值,然後選取 [ 儲存]。 這通常會重新建立遺漏的數據列。