App Center SDK

App Center 是适用于 iOS、Android、Windows 和 macOS 应用的持续集成、交付和学习解决方案。 获取更快的发布周期、更高质量的应用和见解,以生成用户所需的内容。

警告

不要将任何 API 令牌 嵌入源代码中。

App Center Services

App Center SDK 使用模块化体系结构,因此你可以使用以下任何或所有服务。 若要详细了解每个服务如何适用于你的平台,请查看深入文档。

App Center 分析

App Center Analytics 可帮助你了解用户行为和客户参与度,以改进应用。 SDK 自动捕获会话计数、设备属性(如模型、OS 版本等)。可以定义自己的自定义事件来衡量对业务至关重要的事项。 App Center 门户中提供了捕获的所有信息,用于分析数据。

App Center 崩溃

每次应用崩溃时,App Center 崩溃都会自动生成崩溃日志。 日志首先写入设备的存储,当用户再次启动应用时,故障日志将发送到 App Center。 收集崩溃适用于 beta 和实时应用,即提交到 App Store 或 Google Play 的应用。 崩溃日志包含有价值的信息,可帮助你修复故障。

App Center 分发

通过 App Center 分发应用时,App Center SDK 将允许用户安装新版本的应用。 新版本的应用可用后,SDK 将向用户显示一个更新对话框,以下载或推迟更新。 选择更新后,SDK 将开始更新应用程序。 如果你的应用已部署到应用商店,此功能将不起作用。

入门

要求

下表显示了不同 App Center 服务所需的最低支持版本。

Android

Android Studio 2.2 或更高版本。

服务 Android OS 版本 API 级别
分析 5.0 及更高版本 21 及更高版本
崩溃 5.0 及更高版本 21 及更高版本
分发 5.0 及更高版本 21 及更高版本

iOS

服务 iOS 版本 Xcode
分析 9.0 或更高版本 11 及更高版本
崩溃 9.0 或更高版本 11 及更高版本
分发 9.0 或更高版本 11 及更高版本

Unity

服务 Unity 版本 iOS 版本 Android 版本 UWP Windows 版本
分析 2018.1 或更高版本 9.0 或更高版本 5.0 / API 级别 21 或更高版本 10.0.16299 或更高版本
崩溃 2018.1 或更高版本 9.0 或更高版本 5.0 / API 级别 21 或更高版本 不可用
分发 2018.1 或更高版本 9.0 或更高版本 5.0 / API 级别 21 或更高版本 不可用

Windows UWP

服务 Windows 版本 Visual Studio
分析 10 内部版本 16299 Visual Studio 2017 Update 15.9 或更高版本
崩溃 10 内部版本 16299 Visual Studio 2017 Update 15.9 或更高版本
分发 不可用 不可用

WPF 和 WinForms

服务 .NET framework .NET Core Windows 版本 Visual Studio
分析 4.6.1 或更高版本 3.0 或更高版本 10 内部版本 10240 Visual Studio 2017 Update 15.9 或更高版本
崩溃 4.6.1 或更高版本 3.0 或更高版本 10 内部版本 10240 Visual Studio 2017 Update 15.9 或更高版本
分发 不可用 不可用 不可用 不可用

仅当 WPF/WinForms 应用程序在 Windows 上运行时,才支持 .NET Core。

React Native

服务 RN 版本 iOS 版本 Android 版本
分析 0.34 或更高版本 9.0 或更高版本 & 的 Cocoapods 5.0/API 级别 21 或更高版本
崩溃 0.34 或更高版本 9.0 或更高版本 & 的 Cocoapods 5.0/API 级别 21 或更高版本
分发 0.34 或更高版本 9.0 或更高版本 & 的 Cocoapods 5.0/API 级别 21 或更高版本

macOS

服务 macOS 版本 Xcode
分析 10.13 或更高版本 11 或更高版本
崩溃 10.13 或更高版本 11 或更高版本

tvOS

服务 tvOS 版本 Xcode
分析 11.0 或更高版本 11 及更高版本
崩溃 11.0 或更高版本 11 及更高版本

源代码和发行说明

App Center SDK 是开源的,在 GitHub 上公开提供: