问题
2018年9月19日星期三 上午9:00 | 1 票
我们在论坛中已经多次注意到关于Outlook 2016中“签名”按钮不起作用的反馈。比如以下几个英文论坛中的帖子:
在这篇文章中,我们将介绍一些造成这个问题的可能原因以及对应的解决方案。
症状:
在使用Outlook 2016过程中,您可能遇到以下症状中的一个或多个:
- 在新邮件窗口中点击“签名”按钮时,Outlook挂起数秒,无法添加签名
- 点击“文件”选项卡->“选项”->“邮件”下的“签名”按钮时,Outlook没有任何反应
- “文件”选项卡->“选项”->“邮件”下的“签名”或者“信纸和字体”按钮不可点击,显示灰色
原因:
这个问题可能由下列任一原因导致:
▲ 安装的Office程序与电脑上预装 Microsoft Office 桌面应用不兼容
▲ 相关注册表项指向错误的Outlook.exe所在路径
▲ 组织中应用的组策略禁用了“签名”按钮
解决方案:
1. 安装的Office程序与电脑上预装 Microsoft Office 桌面应用不兼容
这是一个已知问题,很多新电脑购买的时候预装了Microsoft Office桌面应用,当您在这样的机器上安装您自己的Office程序的时候,可能发生这个问题。解决的方案是卸载预安装的Microsoft Office桌面应用。具体步骤如下:
- 右键单击 Windows“开始”按钮,然后单击“设置”。
- 单击“应用”,然后单击“应用和功能”。
- 选择 Microsoft Office 桌面应用 并点击 卸载。
- 重启电脑。
(注意:此问题现已在 Office 版本 1802(内部版本 9029.2167)中得到修复。安装该内部版本或更高版本的 Office 订阅时,将自动删除预装的 Microsoft Office 桌面应用。 )
参阅单击“签名”按钮时 Outlook 冻结了解更多详细信息。
2. 相关注册表项指向错误的Outlook.exe所在路径
下文中提到的注册表项***(Default)和LocalServer32***需要准确地指向Outlook.exe所在的路径,否则点击“签名”按钮将不起作用。通常这是因为在同一台电脑上切换Office版本所致(降级到旧版本/升级到新版本,32位版本变为64位版本等)。也有可能是在安装Office的时候,由于您系统中存在的安全软件对注册表的保护过于严;,导致相关的注册表键;没有正确地写入注册表中。相关的注册表所在路径如下,注册表路径因Office版本和Windows版本不同而异:
(注意: 编辑注册表之前,我们建议您对注册表进行备份。如果出现问题,您可以将注册表还原到原始的状态。了解有关如何备份和还原在 Windows 注册表的详细信息。)
- 32位版本Windows或者64位版本Office: HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Wow6432Node\CLSID\0006F03A-0000-0000-C000-000000000046}\LocalServer32
- 64位版本Windows上的32位版本Office:
HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\0006F03A-0000-0000-C000-000000000046}\LocalServer32
在打开的注册表编辑器的右侧面板中,找到***(Default)和LocalServer32***,分别打开这两个注册表子项,确保这两个注册表项的;都指向正确的Outlook.exe所在的路径。如果LocalServer32不存在,请手动创建这个键;(编辑->新建->多字符串;)并指向正确的路径。
默认情况下,Outlook.exe的默认路径如下所示:
32位即点即用版本Outlook 2016:
C:\Program Files (x86)\Microsoft Office 16\root\office16\Outlook.exe
64位即点即用版本Outlook 2016:
C:\Program Files\Microsoft Office 16\root\office16\Outlook.exe
32位MSI版本Outlook 2016:
C:\Program Files (x86)\Microsoft Office\Office16\Outlook.exe
64位MSI版本Outlook 2016:
C:\Program Files\Microsoft Office\Office16\Outlook.exe
虽然上述已经列出各版本Outlook.exe的默认路径供您参考,我们还是建议您打开Windows资源管理器,手动浏览到Outlook.exe所在的路径,并将这个路径作为上述注册表项的;。
3. 组织中应用的组策略禁用了 “签名” 按钮
您的组织管理员可能通过组策略限制了Outlook签名的使用。如果您注意到您的组织中其他用户也有同样的问题,并且“签名“按钮是不可用(灰色)状态,很可能就是组策略导致的。建议您联系您的管理员进一步确认。
如果您遇到类;的问题且通过以上步骤仍未能解决,欢迎随时来我们论坛提问(点击文章页面左上角的“提出问题”按钮快速发帖),我们会帮助您进一步调查这个问题。
如果帖子有帮到您的话,请点击左上方“投票”按钮。这将帮到阅读到这个帖子的其他用户。