对 Partner Connect 进行故障排除

此部分提供有助于解决 Partner Connect 常见问题的信息。

排查一般错误

当你尝试使用 Partner Connect 进行连接时,可能会看到以下一般错误。

尝试连接到合作伙伴时,显示错误消息

问题:尝试使用 Partner Connect 将 Azure Databricks 工作区连接到合作伙伴解决方案时,显示错误,无法创建连接。

原因:

出现此问题的原因可能有多种:

  • 如果组织中有多个人尝试与一个合作伙伴创建帐户,则只有第一个人会成功。 这是因为合作伙伴可能仅在组织级别提供一些帐户,并且创建此类帐户的第一个个人也为组织建立帐户。
  • 如果已有合作伙伴的帐户,连接可能仍然会失败。 这是因为合作伙伴可能会错误地尝试创建重复帐户。

解决方法

执行下列操作之一:

  • 要求向合作伙伴创建组织帐户的第一个个人将你的电子邮件地址添加到该帐户。 然后绕过 Partner Connect 并直接登录到合作伙伴帐户,以开始使用合作伙伴的解决方案。
  • 请尝试再次通过合作伙伴连接建立连接,但这次,请指定与组织域(如个人电子邮件地址)不关联的电子邮件地址。 这可能需要你还将该电子邮件地址作为用户添加到 Azure Databricks 工作区。
  • 绕过 Partner Connect,直接使用现有帐户登录合作伙伴,并开始使用合作伙伴解决方案。

如果在登录合作伙伴后工作区尚未连接,请按照相应合作伙伴连接指南中的说明来完成连接。

尝试登录合作伙伴的帐户或网站时,会弹出拦截器提示

问题:对于使用合作伙伴连接登录到合作伙伴帐户或网站的合作伙伴解决方案,单击“ 登录”时,合作伙伴连接将在 Web 浏览器中打开一个新选项卡,并显示弹出阻止程序。 此弹窗拦截器阻止你登录合作伙伴的帐户或网站。

原因:Web 浏览器在阻止弹出窗口。

解决方案:在 Web 浏览器中允许合作伙伴网站的弹出窗口。 具体说明因 Web 浏览器而异。 例如,对于 Google Chrome,请参阅 Google Chrome 帮助网站上的在 Chrome 中阻止或允许弹出窗口。 对于其他 Web 浏览器,请在 Internet 中搜索“如何允许特定网站的弹出窗口?”这类短语

权限不足,无法创建合作伙伴连接

问题:尝试创建合作伙伴连接时,将显示权限错误,无法创建连接。

原因:此问题可能是因为你不是工作区管理员。

解决方法:帐户管理员或工作区管理员必须将你的用户添加到管理员组。 请参阅

权限不足,无法与 Unity Catalog 管理的数据创建合作伙伴连接

问题:尝试创建合作伙伴连接时,将显示以下 缺少的权限 错误,并且无法创建连接:

You do not have permission to grant <read|write> access to the workspace default catalog. To enable granting <read|write> access to the default catalog or other catalogs, contact an account admin

原因:此问题可能发生,因为你不拥有工作区默认目录。 如果合作伙伴解决方案未通过合作伙伴连接为 Unity Catalog 启用,则您只能连接到默认目录,并且默认目录必须是hive_metastore或您明确拥有的其他目录。

解决方法:采取以下措施之一:

  • 请求默认目录的所有者创建连接。

  • 请求默认目录的所有者将你添加到拥有默认目录的组。 请参阅

  • 请求帐户管理员通过运行 databricks metastores assign 来更改默认目录。 在以下命令示例中,替换下列占位符:

    • <workspace-id> 替换为工作区的 ID。
    • <metastore-id> 替换为元存储的 ID。
    • <catalog-name> 替换为默认目录的名称。
    databricks metastores assign <workspace-id> <metastore-id> <catalog-name>
    

    警告

    更改默认目录可能会中断依赖默认目录的现有数据操作。 具体而言,未指定目录的数据操作会假定使用默认目录。 更改默认值会导致这些操作找不到它们引用的数据对象。

    有关 databricks metastores 命令的详细信息,请参阅 Databricks CLI 命令

现有合作伙伴连接无法再访问 Azure Databricks 数据

问题:当您使用合作伙伴连接登录到现有的合作伙伴帐户,并且合作伙伴尝试访问 Azure Databricks 数据时,会显示一个错误,提示您没有权限访问工作区的默认目录。

原因:如果工作区已启用 Unity 目录,则可能会出现此问题,因为默认目录不是 hive_metastore。 如果合作伙伴解决方案不支持通过合作伙伴连接与 Unity Catalog 管理的数据进行连接,那么这会导致现有连接中断。

解决方法:采取以下措施之一:

  • 与合作伙伴断开连接,然后在指定默认目录的情况下重新连接。 请参阅与合作伙伴断开连接。 此解决方法要求你拥有默认目录。

  • 请求帐户管理员通过运行 hive_metastore 将默认目录更改为 databricks metastores assign。 在以下命令示例中,替换下列占位符:

    • <workspace-id> 替换为工作区的 ID。
    • <metastore-id> 替换为元存储的 ID。
    databricks metastores assign <workspace-id> <metastore-id> hive_metastore
    

    警告

    更改默认目录可能会中断依赖默认目录的现有数据操作。 具体而言,未指定目录的数据操作会假定使用默认目录。 更改默认值会导致这些操作找不到它们引用的数据对象。

    有关 databricks metastores 命令的详细信息,请参阅 Databricks CLI 命令

排查安全错误

本部分提到的安全配置可能会导致 Partner Connect 集成失败。

IP 访问列表

问题:以下警告显示在“ 连接到合作伙伴 ”对话框中,无法创建与合作伙伴的连接:

Partner Connect might not work because IP access list is enabled.

原因:如果在工作区上启用了 IP 访问列表功能,则可能必须将合作伙伴集成添加到允许列表。

解决方案:有关将合作伙伴集成添加到允许列表的步骤,请参阅合作伙伴文档或联系合作伙伴的支持团队。

有关 IP 访问列表的详细信息,请参阅为工作区配置 IP 访问列表

在以下情况下,请按照本部分中的解决方案配置 Azure 专用链接设置以启用合作伙伴集成:

  • 你为工作区启用了前端专用链接连接

  • 你在 Partner Connect 中遇到以下错误

    Partner Connect might not work because front-end Private Link is enabled.
    

解决方案:配置专用链接设置以启用合作伙伴集成。 有关配置专用链接设置的步骤,请参阅合作伙伴文档或联系合作伙伴的支持团队。

有关 Azure 专用链接的详细信息,请参阅启用 Azure 专用链接后端和前端连接

个人访问令牌

问题:尝试创建连接时显示了以下“缺少权限”错误:

Partner Connect requires personal access tokens to be enabled.

原因:如果工作区中禁用了基于令牌的身份验证,则除非使用 Microsoft Entra ID 令牌或 Microsoft Entra ID 帐户凭据通过 Power BI 或 Tableau 进行身份验证,否则无法使用合作伙伴连接与合作伙伴解决方案集成。

有关个人访问令牌的详细信息,请参阅 “监视和撤销个人访问令牌”。