解决 Dynamics 365 的领英企业销售帐号集成错误

本文将帮助您解决与 Dynamics 365 Sales 中的 LinkedIn 集成相关的问题。

启用 LinkedIn 更新时出错

原因

领英企业销售帐号集成设置对话框中启用数据验证选项(启用 LinkedIn 更新)时,您可能会看到数据验证失败状态。 可能的错误为:

  • 数据验证失败,因为在领英企业销售帐号中已禁用 CRM sync。
  • 数据验证失败,并出现其他错误(例如,“意外错误”)。

启用 LinkedIn 更新时出错。

有关领英企业销售帐号的数据验证功能的详细信息,请参阅数据验证

解决

  • 如果由于禁用了 CRM 同步而导致数据验证失败,请验证以下各项:

    • CRM sync 是否在领英企业销售帐号中启用。

    • 是否在领英企业销售帐号中启用了数据验证设置。 如果未启用此设置,即使已启用 CRM 同步,您也会看到 CRM 同步已禁用状态。 如果您无法在领英企业销售帐号中看到数据验证设置,请确保您具有适当的领英企业销售帐号许可证。 详细信息:领英企业销售帐号数据验证 - 概述

    • 如果您已打开这两项设置,请确保您已至少打开了一次启用 LinkedIn 更新设置。

  • 如果错误是由于 CRM sync 之外的其他原因造成的,则可以首先在领英企业销售帐号集成设置对话框中禁用数据验证,然后再次启用它,从而尝试重新启动数据验证。

无法升级 LinkedInSalesNavigatorForUnifiedClient 解决方案

原因

您无法将 LinkedInSalesNavigatorForUnifiedClient 解决方案从 1.x 升级到 3.x。 发生此问题是由于解决方案存在的依赖关系:您无法更新有关联的依赖关系的解决方案。

解决

要解决此问题,必须删除 LinkedInSalesNavigatorForUnifiedClient 解决方案的现有依赖关系。 请按照以下步骤进行操作:

  1. 对于当前的 LinkedInSalesNavigatorForUnifiedClient 解决方案,请删除依赖关系并卸载解决方案。 有关详细信息,请参阅卸载领英企业销售帐号中的步骤 4。

  2. 卸载 msdyn_LinkedInSalesNavigatorAnchor 解决方案。

  3. 在成功删除解决方案后,重新进行安装。 详细信息:安装和启用 LinkedIn Sales Navigator

领英企业销售帐号显示小组件未在不同的 Web 浏览器上正确加载

原因

当我尝试登录领英企业销售帐号时,显示错误。 发生这些错误是由于在浏览器中启用了跟踪保护。 以下是会发生的错误:

  • 显示小组件显示错误—未找到领英企业销售帐号订阅。您需要有领英企业销售帐号团队合同才能获得访问权限

    显示小组件显示未找到订阅错误。

-或-

  • 显示小组件未在不同浏览器上加载。 显示的错误如下面的示例图像所示:

    显示小组件未加载。

解决

要解决此问题,必须在浏览器中禁用跟踪保护(Microsoft EdgeMozilla FireFoxGoogle ChromeApple Safari)。

Microsoft Edge:

  1. 打开 Microsoft Edge 浏览器。
  2. 选择右上方的更多选项图标,转到设置
  3. 从站点地图,转到隐私、搜索和服务
  4. 预防跟踪部分,选择平衡并禁用 InPrivate 浏览时始终使用“严格”预防跟踪选项。

    Edge 中的配置预防跟踪部分。

Mozilla FireFox:

  1. 打开 Mozilla FireFox 浏览器并打开您的组织。
  2. 在地址栏前面,选择屏蔽图标,“增强的跟踪保护详细信息”将出现。
  3. 禁用此站点的增强的跟踪保护打开选项并刷新浏览器。

    Firefox 中的配置预防跟踪部分。

  4. 刷新页面,显示小组件将按预期开始加载。

Google Chrome:
在 Chrome 浏览器中,显示小组件加载问题可能会在 Incognito/专用模式下发生。
在 Incognito/专用模式下浏览组织时,请禁用阻止第三方 Cookie 选项。 显示小组件将按预期加载。

Chrome 中的配置预防跟踪部分。

Apple Safari:

  1. 打开 Apple Safari 浏览器并打开您的组织。
  2. 转到首选项,配置以下选项:
    • LinkedIn 和您的 Dynamics 365 组织不在内容阻止程序的阻止列表中。
    • 您的 Dynamics 365 组织允许弹出窗口。
    • 隐私选项卡中,未选择阻止跨站点跟踪阻止所有 Cookie 选项。

无法查看统一接口中自定义联系人和潜在顾客窗体上的照片

原因
默认情况下,来自 LinkedIn 照片显示在现成的“联系人”和“潜在顾客”窗体中。 对于自定义窗体,默认情况下无法显示照片。

解决
要解决此问题,请将 msdyn_linkedinintegrationcommon.js 库和 LinkedInIntegration.LinkedInIntegrationCommon.Instance.Form_OnLoad 函数句柄添加到自定义窗体中。 请按照以下步骤进行操作:

  1. 登录到您的 Dynamics 365 应用。
  2. 转到高级设置>自定义>自定义系统
  3. 实体站点地图中,选择实体,然后选择要显示照片的自定义窗体。

    备注

    在此过程中,我们使用的是联系人自定义窗体。

  4. 选择窗体属性选项。
    窗体属性对话框打开。

    窗体属性对话框。

  5. 窗体库部分,搜索并将 msdyn_linkedinintegrationcommon.js 库添加到窗体中。
  6. 事件句柄部分,搜索并将 LinkedInIntegration.LinkedInIntegrationCommon.Instance.Form_OnLoad 函数添加到窗体中。

    添加到窗体的 LinkedIn 库和函数。

  7. 保存并发布窗体。

LinkedInSalesNavigatorControlsForUnifiedClient 解决方案在组织中不可用,无法配置领英企业销售帐号

原因
LinkedInSalesNavigatorControlsForUnifiedClient 解决方案仅在具有领英企业销售帐号解决方案版本 2.2.0.1 及更高版本的组织中可用。 如果 LinkedIn 解决方案版本低于 2.2.0.1,则手动安装 LinkedInSalesNavigatorControlsForUnifiedClient 解决方案。

解决
若要解决此问题,请删除解决方案并重新安装它们。

备注

删除并安装解决方案可能导致丢失 li_inmailsli_messageli_pointdrivepresentationviewed 实体的数据。 从这些实体中导出数据,并在安装后进行还原。

请按照以下步骤进行操作:

  1. 删除领英企业销售帐号解决方案。 在删除解决方案之前,验证依赖项(如果存在),与您的系统管理员联系以删除解决方案。 要移除依赖项,请执行以下步骤:
    1. 转到高级设置>自定义>解决方案
    2. 选择 LinkedIn 解决方案,然后选择显示依赖项

      LinkedIn 解决方案依赖项。

    3. 选择需求者实体名称,在页面中打开依赖实体。
    4. 选择窗体属性,然后在事件选项卡下,转到事件处理程序部分。
    5. 选择并删除事件。
    6. 保存并发布自定义。
  2. 删除 msdyn_LinkedInSalesNavigatorAnchor 解决方案。
  3. 再次安装领英企业销售帐号解决方案,并还原实体的数据。

另请参见

Dynamics 365 Sales 疑难解答指南