原始 KB 编号: 2725168
问题
使用 Microsoft Outlook 2011 for Mac 连接到 Microsoft 365 中的 Microsoft Exchange Online 帐户时,电子邮件服务器设置不会自动设置为Exchange Online。 因此,您尝试手动设置 Outlook 2011 for Mac 以连接到Exchange Online。 但是,设置失败,并且无法使用 Outlook 2011 for Mac 访问Exchange Online帐户。
原因
如果在 Exchange Online 中关闭 Microsoft Exchange Web Services (EWS) ,则会出现此问题。
解决方案
若要解决此问题,请在 Exchange Online 中启用 EWS。 为此,请按照下列步骤操作:
通过使用远程 PowerShell 连接到 Exchange Online。 有关如何执行此操作的信息,请参阅连接到 Exchange Online PowerShell。
在 Exchange Online 中启用 EWS。 为此,请根据自己的情况运行以下 cmdlet 之一:
对于单个用户
Set-CASMailbox -EwsAllowOutlook $true -Identity "ONLINE USERNAME"
对于整个组织
Get-Mailbox | Set-CASMailbox -EwsAllowOutlook $true
更多信息
EWS 包括以下 Web 服务:
- 自动发现
- 可用性
- 邮件传递记录管理
- 通知
- 同步
- Exchange 数据服务
仍然需要帮助? 请转到 Microsoft 社区。