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Outlook 用户无法访问 Exchange Server 2013 或 Exchange Server 2016 中的公用文件夹

原始 KB 数: 2788136

现象

Microsoft Outlook 用户尝试访问 Exchange Server 2013 或 Exchange Server 2016 中的公用文件夹时,将显示以下对话框:

“Microsoft Exchange”对话框的屏幕截图。

但是,如果用户在此对话框中单击“确定,则它们未连接到公用文件夹。

此外,用户可能会收到以下错误消息:

无法展开文件夹。 无法打开文件夹集。 文件 C:\Users\<username>\AppData\Local\Microsoft\Outlook\filename.ost 正在使用且无法访问。 关闭使用此文件的任何应用程序,然后重试。 可能需要重新启动计算机。

原因

出现此问题的原因是自动发现服务无法发现在公用文件夹邮箱上标记的电子邮件地址。

解决方法

若要解决此问题,请使用以下一种方法:

  • 为在公用文件夹邮箱上标记的电子邮件地址创建与自动发现相关的 DNS 记录。 有关 Exchange 2010 自动发现服务的详细信息,请参阅 白皮书:了解 Exchange 2010 自动发现服务

    有关如何在 Outlook 2010 中自动配置用户帐户的详细信息,请参阅 计划在 Outlook 2010 中自动配置用户帐户。

  • 更改公用文件夹邮箱的电子邮件地址以匹配已发布自动发现记录的电子邮件域。

详细信息

从 Exchange Server 2013 和 Exchange Server 2016 中删除公用文件夹数据库概念。 公用文件夹现在存储在称为公用文件夹邮箱的新邮箱中。

Outlook 客户端取决于自动发现服务返回的信息来访问公用文件夹邮箱。

下面是自动发现服务返回的公用文件夹邮箱信息的示例:

<PublicFolderInformation>  
    <SmtpAddress>PFMailbox@contoso.com</SmtpAddress>  
</PublicFolderInformation>

在此示例中,Outlook 客户端尝试自动发现PFMailbox@contoso.com。 但是,如果与不存在相关的 Contoso.com DNS 记录,公用文件夹访问将失败。