(WinRM 客户端在通过远程Windows PowerShell连接到Exchange Online时无法处理请求) 错误

问题

使用远程Windows PowerShell连接到 Microsoft 365 中的Exchange Online时,会收到以下错误消息:

[outlook.office365.com]连接到远程服务器失败,并显示以下错误消息:
WinRM 客户端无法处理请求,因为无法解析服务器名称。 有关详细信息,请参阅about_Remote_Troubleshooting帮助主题。

+ CategoryInfo : OpenError:
(System.Manageme....RemoteRunspace:RemoteRunspace) []。
PSRemotingTransportException

+ FullyQualifiedErrorId:PSSessionOpenedFailed

原因

在下列情况之一中会出现此问题:

  • 防火墙会阻止必要的流量。
  • Windows 远程管理服务未启动。
  • 代理服务器无法正常工作。

解决方案

  • 确保防火墙不会阻止必要的流量。

  • 检查 Windows 远程管理服务是否已安装并已启动:

    1. 在“运行”对话框中键入 services.msc,然后按 Enter。

    2. 在“服务 MMC”中,双击“ Windows 远程管理”。

    3. 将启动类型设置为 “手动”,然后单击“ 确定”。

    4. 右键单击该服务,然后选择“ 启动”。

    5. 让服务启动。

      注意

      如果服务已启动,但未响应,则可能需要单击“ 重启”。

    6. 尝试再次连接到Exchange Online。

  • 检查代理服务器设置

    1. 打开提升的命令提示符。

    2. 运行以下命令以验证当前代理配置:

      netsh winhttp show proxy
      
    3. 执行下列操作之一:

      • 若要重置 WinHTTP 代理,请运行以下命令:

        netsh winhttp reset proxy
        
      • 若要配置新的代理服务器,请运行以下命令:

        netsh winhttp set proxy <proxy>:<port>
        

        例如,运行 netsh winhttp set proxy 10.0.0.6:8080

更多信息

有关 Microsoft 365 终结点的详细信息,请参阅 Microsoft 365 URL 和 IP 地址范围

有关如何使用远程 PowerShell 连接到 Exchange Online 的详细信息,请转到使用远程 PowerShell 连接到 Exchange Online

仍然需要帮助? 请转到 Microsoft 社区