Outlook 中的日历提醒无法消除或继续重新出现

症状

尝试在 Microsoft Outlook 中关闭日历提醒时,你发现它们无法消除或继续重新出现。

原因

提醒文件夹或提醒视图已损坏。 同步冲突还可能会阻止 Outlook 关闭提醒。

解决方法 1

使用命令行删除项:

  1. 关闭 Outlook。

  2. 在 Windows 中右键单击“ 开始” 按钮,然后选择“ 运行”。

  3. “运行” 窗口中,键入或粘贴以下命令,然后选择 Enter

    outlook.exe /cleanreminders
    

如果该方法不起作用,请使用解决方法 2。

解决方法 2

使用 Microsoft Exchange Server MAPI 编辑器 (MFCMAPI) 删除 Reminders 文件夹。 为此,请按照下列步骤操作:

  1. github 下载 MFCMAPI (向下滚动,然后单击“最新版本) ”。

  2. 退出 Outlook。

  3. 打开 MFCMAPI。

  4. 在“工具”菜单上,单击“选项”,选择以下两个检查框 ((如果尚未选择) ),然后单击“确定”:

    • 调用 OpenMsgStore 时使用 MDB_Online 标志
    • 调用 OpenEntry 时使用 MAPI_NO_CACHE 标志
  5. 单击“ 会话”,单击“ 登录”,选择要更改的配置文件,然后单击“ 确定”。

  6. 双击要打开的邮箱存储。

  7. 展开 “根容器”。

  8. 右键单击“ 提醒” 文件夹,然后单击“ 删除文件夹”。

    注意

    请勿删除 Reminders 文件夹中的各个项目。 Reminders 文件夹只是日历上即将发生的事件的视图。 如果删除文件夹中的项目,将从日历中删除这些项目。

  9. 运行 Outlook.exe /cleanremindersOutlook.exe /ResetFolders 命令行。 (此步骤将重新创建 Reminders 文件夹,并将所有有效的条目重新添加到 in.)

解决方法 3

可以通过清除“日历”文件夹中的所有脱机项目来修复同步问题。 这将从本地副本中删除所有项,但可以从服务器再次下载它们。

  1. 右键单击受影响的日历,然后选择“属性”>“清除脱机项目>确定”。 日历上的所有项目都将被删除。
  2. 在功能区中选择“ 发送/接收>更新文件夹 ”以强制下载项目。