会议室邮箱不处理通过第三方邮件服务路由的会议请求

症状

请考虑以下情况:

  • 你的环境包括Exchange Online但没有混合 Exchange 部署。
  • 你的环境使用第三方邮件服务和邮件流连接器将电子邮件路由到你的 Microsoft 365 组织。 出站连接器将邮件从组织路由到第三方邮件服务,入站连接器将邮件从第三方邮件服务路由到组织。

在此方案中,当你安排与组织内部用户的会议,并在会议邀请中指定会议室时,会议室的会议室邮箱不会自动接受或拒绝会议,即使它已设置为执行此操作也是如此。

如果运行以下 cmdlet 来验证为会议室邮箱设置的自动日历处理选项,则输出中 属性的值 AutomateProcessing 将显示为 AutoAccept

Get-CalendarProcessing -Identity <name_of_room_mailbox> | select AutomateProcessing

原因

出现此问题是因为会议室邮箱通过入站连接器从第三方邮件服务收到的邀请视为外部邮件。

解决方案

若要解决此问题,请使用以下方法之一:

方法 1:允许会议室邮箱处理来自外部用户的请求

此方法允许 Microsoft 365 组织外部的用户预订与会议室邮箱关联的会议室。 但是,组织所涉及的风险很小,因为外部用户不太可能知道会议室邮箱的电子邮件地址。

Exchange Online PowerShell 中,运行以下 cmdlet:

Set-CalendarProcessing -Identity <name_of_room_mailbox > -ProcessExternalMeetingMessages $True

方法 2:设置入站连接器以将外部消息视为内部消息

警告

此方法存在潜在的安全风险,因为内部消息绕过反垃圾邮件筛选。 必须确保通过第三方邮件服务路由的邮件仅供内部使用。

若要使用此方法,必须将入站连接器的参数值 ConnectorType 设置为 OnPremises。 有关详细信息,请参阅 Set-InboundConnector cmdlet 中有关使用 TreatMessagesAsInternal 参数的部分。

Exchange Online PowerShell 中,运行以下 cmdlet:

Set-InboundConnector -Identity <name_of_inbound_connector > -TreatMessagesAsInternal $True 

更多信息

发生此问题时,可以检查 RBA 日志和消息跟踪,如下所示:

检查 RBA 日志

  1. Exchange Online PowerShell 中,运行以下 cmdlet 以导出会议室邮箱的 RBA 日志:

    Export-MailboxDiagnosticLogs <name_of_room_mailbox > -ComponentName RBA > RoomMBXLogs.txt
    
  2. 在 RBA 日志中,检查以下条目:

    消息跳过处理,因为用于处理外部项的用户设置为 false。

    此条目的时间戳将与邮箱收到的会议请求的时间戳紧密匹配。

此条目指示未处理会议邀请,因为它被视为外部消息。

检查消息跟踪

  1. 运行 扩展消息跟踪

  2. 在邮件跟踪中,在“自定义”列中找到 RECEIVE 事件,以标识会议邀请路由到组织外部的出站连接器,以及用于将邀请路由回组织的入站连接器。

  3. 运行以下 cmdlet 以检查消息跟踪中列出的入站连接器的详细信息:

    Get-InboundConnector -Identity <name_of_inbound_connector> | flConnectorType,Enabled, TreatMessagesAsInternal
    

输出将显示参数的以下值:

ConnectorType:Partner
已启用:True
TreatMessagesAsInternal: False

这些值指示会议邀请未处理,因为它被视为外部消息。