Outlook 无法通过防火墙或正在执行网络地址转换的代理服务器进行连接, (公用网络和专用网络之间的 NAT)

原始 KB 编号: 291615

症状

Outlook 客户端无法通过防火墙或代理服务器进行连接,该服务器在公用网络和专用网络之间执行 NAT。

原因

在转换过程中编辑包含远程过程调用 (RPC) 信息的 IP 数据包时,IP 数据包将丢失 RPC 连接信息。 这会导致客户端无法连接到服务器。 此外,在解决防火墙或代理服务器后面的Microsoft Exchange Server计算机名称时,Outlook 可能遇到问题。

解决方法

不基于 Microsoft Windows NT的防火墙或代理服务器的解决方法是在两个网络之间执行一对一转换。 这也称为在公用网络和专用网络之间 打开管道或隧道 。 这会接受对公用网络上特定地址的所有请求,并将其直接传递到专用网络。 有关如何配置一对一翻译的其他信息,请参阅制造商的文档。

一对一转换或管道不适用于基于Windows NT的防火墙和代理服务器,因为 Outlook 客户端尝试绑定到防火墙上的终结点映射器端口 (EPM) 端口 135。 此服务器不会向 Outlook 客户端返回正确的Exchange Server连接信息。

另一个可能的解决方法是使用Outlook Web App。 这只需要允许 HTTP 流量通过防火墙或代理服务器。

更多信息

有关详细信息,请参阅以下 RFC (注释请求) :

  • RFC 1631 - IP 网络地址转换器 (NAT)
  • RFC 1918 - 专用 Internet 的地址分配

在此处找到这些 RFC。